ipq40xx: replace ${} with $()
authorSungbo Eo <mans0n@gorani.run>
Tue, 10 Mar 2020 04:42:57 +0000 (13:42 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 11 Mar 2020 18:24:37 +0000 (19:24 +0100)
${} and $() are exactly the same. Follow the convention of using $().

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ipq40xx/image/Makefile

index 50ea03d659c621e70e52b52aa7ac4d1553572eea..2e95ad4dfb277f9d183559c4c14131d3b0a6acd8 100644 (file)
@@ -419,7 +419,7 @@ define Device/linksys_ea6350v3
        IMAGE_SIZE := 37888k
        UBINIZE_OPTS := -E 5
        IMAGES := factory.bin sysupgrade.bin
-       IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$${KERNEL_SIZE} | append-ubi | linksys-image type=EA6350v3
+       IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
        DEVICE_PACKAGES := uboot-envtools
 endef
 TARGET_DEVICES += linksys_ea6350v3
@@ -435,7 +435,7 @@ define Device/linksys_ea8300
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES := sysupgrade.bin factory.bin
-       IMAGE/factory.bin  := append-kernel | pad-to $$$${KERNEL_SIZE} | append-ubi | linksys-image type=EA8300
+       IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
        DEVICE_PACKAGES := uboot-envtools ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += linksys_ea8300
@@ -521,7 +521,7 @@ define Device/qcom_ap-dk01.1-c1
        IMAGE_SIZE := 26624k
        $(call Device/FitImage)
        IMAGES := sysupgrade.bin
-       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
+       IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += qcom_ap-dk01.1-c1