toolchain/musl: update to version 1.1.21
authorChristian Lamparter <chunkeey@gmail.com>
Tue, 22 Jan 2019 15:24:11 +0000 (16:24 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Tue, 5 Feb 2019 18:35:40 +0000 (19:35 +0100)
<https://www.openwall.com/lists/musl/2019/01/21/8>
"This release makes improvements with respect to default thread stack
size, including increasing the default from 80k to 128k, increasing
the default guard size from 4k to 8k, and allowing the default to be
increased via ELF headers so that programs that need larger stacks can
be build without source-level changes, using just LDFLAGS.
Insufficient stack size for AIO threads on kernels that don't honor
the constant MINSIGSTKSZ is also fixed.

The glob core has been rewritten to fix inability to see past
searchable-but-unreadable path components, and to avoid excessive
stack usage and unnecessary syscalls. The tsearch AVL tree
implementation has also been rewritten for better size and
performance. The math library adds more native single-instruction
implementations for arm, s390x, powerpc, and x86_64.

Various bugs are fixed, including several possible deadlocks, one of
which was a new regression in 1.1.20."

detailed release notes can be found in the WHATSNEW file:
<http://git.musl-libc.org/cgit/musl/tree/WHATSNEW#n1989>

Tested-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
toolchain/musl/common.mk
toolchain/musl/patches/110-read_timezone_from_fs.patch
toolchain/musl/patches/200-add_libssp_nonshared.patch

index 40c6273e63b985c35f0320ffd0620360f9822ec9..b52263c43b84ee0717b45157159c83a48f011453 100644 (file)
@@ -8,13 +8,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=musl
-PKG_VERSION:=1.1.20
-PKG_RELEASE:=2
+PKG_VERSION:=1.1.21
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0fa1e638e87cf257e9f96b4019b2076afd674a19
-PKG_MIRROR_HASH:=0a49559e845f51aaf006539176a36d6527957affd2838e71fd43275b737e90fe
+PKG_SOURCE_VERSION:=1691b23955590d1eb66a11158fdd91c86337e886
+PKG_MIRROR_HASH:=4fa312d0ca020d31603ced84a7103fb328c6ae9508239491a228be17e7807147
 PKG_SOURCE_URL:=git://git.musl-libc.org/musl
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
index fb98f7d10ee83155f4d46ee1a226c082c0d9d9a4..f92781f7ed8aad3b673c60064f914adffb053899 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/time/__tz.c
 +++ b/src/time/__tz.c
-@@ -23,6 +23,9 @@ static int r0[5], r1[5];
+@@ -25,6 +25,9 @@ static int r0[5], r1[5];
  static const unsigned char *zi, *trans, *index, *types, *abbrevs, *abbrevs_end;
  static size_t map_size;
  
index b8fa7b4b4f3c155b61d9d34b169b0ac14fe9ab20..05bd2fe54a3844c29879e8af13b847ce47cb8216 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
 +OBJ_DIRS = $(sort $(patsubst %/,%,$(dir $(ALL_LIBS) $(ALL_TOOLS) $(ALL_OBJS) $(GENH) $(GENH_INT))) obj/include obj/libssp_nonshared)
  
  $(ALL_LIBS) $(ALL_TOOLS) $(ALL_OBJS) $(ALL_OBJS:%.o=%.lo) $(GENH) $(GENH_INT): | $(OBJ_DIRS)
-
 @@ -113,6 +113,8 @@ obj/crt/rcrt1.o: $(srcdir)/ldso/dlstart.
  
  obj/crt/Scrt1.o obj/crt/rcrt1.o: CFLAGS_ALL += -fPIC
@@ -34,7 +34,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
  OPTIMIZE_SRCS = $(wildcard $(OPTIMIZE_GLOBS:%=$(srcdir)/src/%))
  $(OPTIMIZE_SRCS:$(srcdir)/%.c=obj/%.o) $(OPTIMIZE_SRCS:$(srcdir)/%.c=obj/%.lo): CFLAGS += -O3
  
-@@ -165,6 +166,11 @@ lib/libc.a: $(AOBJS)
+@@ -165,6 +167,11 @@ lib/libc.a: $(AOBJS)
        $(AR) rc $@ $(AOBJS)
        $(RANLIB) $@