kernel: bump 5.4 to 5.4.46
authorPetr Štetiar <ynezz@true.cz>
Fri, 12 Jun 2020 10:32:11 +0000 (12:32 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 16 Jun 2020 21:36:26 +0000 (23:36 +0200)
Refreshed patches.

Run tested: qemu-x86-64, wrt3200acm
Build tested: x86/64, imx6, mvebu/cortexa9, sunxi/a53

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/layerscape/patches-5.4/701-net-0262-net-dsa-ocelot-add-tagger-for-Ocelot-Felix-switches.patch
target/linux/ramips/patches-5.4/401-net-ethernet-mediatek-support-net-labels.patch

index 89e26f6d960df27eb332b382e2be11c92fbfde52..fa62ccbe2a6533bd77c4b49a39cda5b66a58d02c 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.14 = .180
 LINUX_VERSION-4.19 = .123
-LINUX_VERSION-5.4 = .45
+LINUX_VERSION-5.4 = .46
 
 LINUX_KERNEL_HASH-4.14.180 = 444ef973d9b6a6ea174e4a9086f0aea980d8575d13302e431ad688f22e27ed0e
 LINUX_KERNEL_HASH-4.19.123 = a79914d31a8d8c6b0e2bb0f2b143d615fe8a6c4dd2e0f36e97aa20efd69a993f
-LINUX_KERNEL_HASH-5.4.45 = 103f039f34a9009c42ea643b4f473bda6bb9607d5ad7f63b56b3e2351615fe2e
+LINUX_KERNEL_HASH-5.4.46 = 30074ff2f1a2498da391fad73fc0efaa2256416a08fff8835069b1c59ab31b8e
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index f26850035aa326f4bf996d67c392fc91972443c7..38d9e0b5bd5575afe139d0c80c5dc64678641182 100644 (file)
@@ -73,7 +73,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  struct packet_type;
 --- a/net/dsa/Kconfig
 +++ b/net/dsa/Kconfig
-@@ -79,6 +79,13 @@ config NET_DSA_TAG_KSZ
+@@ -80,6 +80,13 @@ config NET_DSA_TAG_KSZ
          Say Y if you want to enable support for tagging frames for the
          Microchip 8795/9477/9893 families of switches.
  
index 69e3c296cafde9b95dab63541dfd5b19f7d62258..206826c1b2e343fbf3028cea00ffb7f482e7f02a 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
 
 --- a/drivers/net/ethernet/mediatek/mtk_eth_soc.c
 +++ b/drivers/net/ethernet/mediatek/mtk_eth_soc.c
-@@ -2779,6 +2779,7 @@ static const struct net_device_ops mtk_n
+@@ -2784,6 +2784,7 @@ static const struct net_device_ops mtk_n
  
  static int mtk_add_mac(struct mtk_eth *eth, struct device_node *np)
  {
@@ -22,7 +22,7 @@ Signed-off-by: René van Dorst <opensource@vdorst.com>
        const __be32 *_id = of_get_property(np, "reg", NULL);
        struct phylink *phylink;
        int phy_mode, id, err;
-@@ -2869,6 +2870,9 @@ static int mtk_add_mac(struct mtk_eth *e
+@@ -2874,6 +2875,9 @@ static int mtk_add_mac(struct mtk_eth *e
        eth->netdev[id]->irq = eth->irq[0];
        eth->netdev[id]->dev.of_node = np;