toolchain: gdb: enable TUI
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 4 Sep 2017 19:20:12 +0000 (20:20 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 3 Jul 2018 13:19:10 +0000 (14:19 +0100)
The GDB Text User Interface (TUI) is a terminal interface
which uses the curses library to show the source file,
the assembly output, the program registers and GDB
commands in separate text windows.

In other words it's a friendlier interface for idiots like me!

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
toolchain/gdb/Makefile

index 5c80eef9aad3c70361f12a20539a79eeaef6963e..fda3401961450f4ce6e532bd4ef0b848c5729a32 100644 (file)
@@ -41,7 +41,7 @@ HOST_CONFIGURE_ARGS = \
        --target=$(REAL_GNU_TARGET_NAME) \
        --disable-werror \
        --without-uiout \
-       --disable-tui --disable-gdbtk --without-x \
+       --enable-tui --disable-gdbtk --without-x \
        --without-included-gettext \
        --enable-threads \
        --with-expat \