tplink-safeloader: increase kernel partition for CPE/WBSx10v1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 19 Jul 2019 12:58:44 +0000 (14:58 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 7 Aug 2019 16:04:03 +0000 (18:04 +0200)
This is a preparation for ath79 support of the CPE210/CPE510 v1.
Kernel size is chosen equal to the latest update for CPE610 v1.

This also updates the partition size in ar71xx target, so code
remains consistent if someone looks up the device. Since CPE210,
CPE510, WBS210 and WBS510 (all v1) share the same partition
layout definition, and are on deprecated target anyway, this
changes them all at once.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ar71xx/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index e448e5123aa193c2bce9b9a3abf47a1899b3f8b0..90cd2a03620d0d0d7f154a48d957f326d1bbafdb 100644 (file)
@@ -172,7 +172,7 @@ define Device/cpe510-520-v1
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
   DEVICE_PACKAGES := rssileds
-  MTDPARTS := spi0.0:128k(u-boot)ro,64k(partition-table)ro,64k(product-info)ro,1792k(kernel),5888k(rootfs),192k(config)ro,64k(ART)ro,7680k@0x40000(firmware)
+  MTDPARTS := spi0.0:128k(u-boot)ro,64k(partition-table)ro,64k(product-info)ro,2048k(kernel),5632k(rootfs),192k(config)ro,64k(ART)ro,7680k@0x40000(firmware)
   IMAGE_SIZE := 7680k
 endef
 TARGET_DEVICES += cpe510-520-v1
index cfd36459509e0bffe6886a24924bc5e3ef24eb5e..55f1ab9420881a17a56c66bc2f4e219e124647cb 100644 (file)
@@ -140,8 +140,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x1c0000},
-                       {"file-system", 0x200000, 0x5b0000},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -264,8 +264,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x1c0000},
-                       {"file-system", 0x200000, 0x5b0000},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -420,8 +420,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x1c0000},
-                       {"file-system", 0x200000, 0x5b0000},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},
@@ -452,8 +452,8 @@ static struct device_info boards[] = {
                        {"default-mac", 0x30000, 0x00020},
                        {"product-info", 0x31100, 0x00100},
                        {"signature", 0x32000, 0x00400},
-                       {"os-image", 0x40000, 0x1c0000},
-                       {"file-system", 0x200000, 0x5b0000},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
                        {"soft-version", 0x7b0000, 0x00100},
                        {"support-list", 0x7b1000, 0x00400},
                        {"user-config", 0x7c0000, 0x10000},