ath79: add support for the TP-Link WBS210 v1
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 15 Apr 2020 19:51:59 +0000 (21:51 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 16 Jun 2020 12:42:15 +0000 (14:42 +0200)
Specifications:
- SoC: Atheros AR9344
- RAM: 64MB
- Storage: 8 MB SPI NOR
- Wireless: 2.4GHz N based built into SoC
- Ethernet: 1x 10/100 Mbps with 24V POE IN, 1x 10/100 Mbps

Installation:
Flash factory image through stock firmware WEB UI
or through TFTP
To get to TFTP recovery just hold reset button while powering on for
around 4-5 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP adress:192.168.0.254

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar9344_tplink_wbs210-v1.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/board.d/03_gpio_switches
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/ar9344_tplink_wbs210-v1.dts b/target/linux/ath79/dts/ar9344_tplink_wbs210-v1.dts
new file mode 100644 (file)
index 0000000..b89c0e2
--- /dev/null
@@ -0,0 +1,13 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9344_tplink_cpe_2port.dtsi"
+
+/ {
+       compatible = "tplink,wbs210-v1", "qca,ar9344";
+       model = "TP-Link WBS210 v1";
+};
+
+&led_link4 {
+       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+};
index 5521379cea62944c1d21bfdb1bf4a55b52b1822b..8029cf7b5e1c4a8ce3b0813c3fd1134048a8e0cf 100755 (executable)
@@ -212,6 +212,7 @@ tplink,cpe210-v1|\
 tplink,cpe220-v2|\
 tplink,cpe220-v3|\
 tplink,cpe510-v1|\
+tplink,wbs210-v1|\
 tplink,wbs210-v2|\
 tplink,wbs510-v1|\
 tplink,wbs510-v2)
index 283e5104164f4dcdcce7b1f82750fcd7377c6359..f2ba49764b8df0a4bb8ac18bdcd1fbeece053270 100755 (executable)
@@ -110,6 +110,7 @@ ath79_setup_interfaces()
        tplink,cpe220-v2|\
        tplink,cpe220-v3|\
        tplink,cpe510-v1|\
+       tplink,wbs210-v1|\
        tplink,wbs210-v2|\
        tplink,wbs510-v1|\
        tplink,wbs510-v2|\
index 66b2a3e1d8ba47d532d4368587e21d500e499f55..cc1b8ff41263f7c3119940c6865fe6fad5df7b47 100755 (executable)
@@ -66,6 +66,7 @@ tplink,cpe210-v1|\
 tplink,cpe220-v2|\
 tplink,cpe220-v3|\
 tplink,cpe510-v1|\
+tplink,wbs210-v1|\
 tplink,wbs210-v2|\
 tplink,wbs510-v1|\
 tplink,wbs510-v2)
index 5fb36ca621585275db35ad87eb7c3c91d8d83944..bd7eb3fc7608764854e2bbe3cefb2044ff6230f9 100644 (file)
@@ -650,6 +650,18 @@ define Device/tplink_tl-wr902ac-v1
 endef
 TARGET_DEVICES += tplink_tl-wr902ac-v1
 
+define Device/tplink_wbs210-v1
+  $(Device/tplink-safeloader-okli)
+  SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := WBS210
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := WBS210
+  SUPPORTED_DEVICES += wbs210
+endef
+TARGET_DEVICES += tplink_wbs210-v1
+
 define Device/tplink_wbs210-v2
   $(Device/tplink-safeloader-okli)
   SOC := ar9344