toolchain: Remove binutils 2.29 for ARC targets
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Wed, 27 Feb 2019 10:09:34 +0000 (10:09 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 20 Mar 2019 17:23:39 +0000 (18:23 +0100)
Remove binutils 2.29 for ARC targets

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
toolchain/binutils/Config.in
toolchain/binutils/Config.version
toolchain/binutils/Makefile

index 231c1975c3f20ce479822b88380012fcef0b35d8..685e89be96daa770c34ea01e0c71b9da3bc8224c 100644 (file)
@@ -7,11 +7,6 @@ choice
        help
          Select the version of binutils you wish to use.
 
-       config BINUTILS_USE_VERSION_2_29_ARC
-               depends on arc
-               bool "ARC binutils 2.29"
-               select BINUTILS_VERSION_2_29_ARC
-
        config BINUTILS_USE_VERSION_2_29_1
                depends on !arc
                bool "Binutils 2.29.1"
index 3a0fc5b43ff9f7e260afe3419ad641291e16880d..3ffcf5734738613dd92339aa4c852a36bf05d3fa 100644 (file)
@@ -1,6 +1,3 @@
-config BINUTILS_VERSION_2_29_ARC
-       bool
-
 config BINUTILS_VERSION_2_29_1
        bool
 
@@ -17,4 +14,3 @@ config BINUTILS_VERSION
        default "2.29.1"               if BINUTILS_VERSION_2_29_1
        default "2.31.1"               if BINUTILS_VERSION_2_31_1
        default "2.32"                 if BINUTILS_VERSION_2_32
-       default "arc-2017.09"          if BINUTILS_VERSION_2_29_ARC
index 6f7b2cb75a3f2de0d442f09ea54990c75c0cb447..1a0b1bce0535c77bd10a86818fc42f7dfc4a392f 100644 (file)
@@ -27,15 +27,6 @@ ifeq ($(PKG_VERSION),2.32)
   PKG_HASH:=0ab6c55dd86a92ed561972ba15b9b70a8b9f75557f896446c82e8b36e473ee04
 endif
 
-ifneq ($(CONFIG_BINUTILS_VERSION_2_29_ARC),)
-  PKG_REV:=arc-2017.09-release
-  PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/$(PKG_REV)/
-  PKG_SOURCE:=$(PKG_NAME)-$(PKG_REV).tar.gz
-  PKG_HASH:=2ea086fd5521e942926dd6ff6922ce31c29ee7ffc754fca3d06385e0f27600f8
-  BINUTILS_DIR:=$(PKG_NAME)-gdb-$(PKG_REV)
-  HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
-endif
-
 HOST_BUILD_PARALLEL:=1
 
 PATCH_DIR:=./patches/$(PKG_VERSION)