build: have config-clean deal with old temp files
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sun, 19 Apr 2020 23:12:52 +0000 (20:12 -0300)
committerPetr Štetiar <ynezz@true.cz>
Wed, 20 May 2020 15:03:45 +0000 (17:03 +0200)
This is a temporary commit to have 'make config-clean' remove
temporary files from the previous scripts/config version.

The .gitignore file is updated to deal with the old files as well.

Cc: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
scripts/config/.gitignore
scripts/config/Makefile

index b5bf92f66d11c44b03c56448f2b267997ba1b64d..737c5b7953a4ca490c326707305ba7850ef56c19 100644 (file)
@@ -12,3 +12,10 @@ mconf
 nconf
 qconf
 gconf
+
+#
+# temporary files from older version.  Should be removed
+#
+zconf.???.c
+zconf.hash.c
+.tmp_qtcheck
index eb55b759a8157d996bf8ee4b637a0aa625d9b0fa..d98f15c393779dbdb8f8e63e976402d32ab3c8c8 100644 (file)
@@ -7,7 +7,10 @@ all: conf mconf
 clean:
        rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf
 
-clean-files    :=
+# This clean-files definition is here to ensure that temporary files from the
+# previous version are removed by make config-clean.
+# It should be removed or emptied when this Makefile get updated again.
+clean-files    := zconf.tab.c zconf.lex.c zconf.hash.c .tmp_qtcheck
 
 # ===========================================================================
 # Variables needed by the upstream Makefile