kernel: bump 4.9 to 4.9.205
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Nov 2019 09:52:01 +0000 (10:52 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Nov 2019 16:05:38 +0000 (17:05 +0100)
Refreshed all patches.

Fixes:
- CVE-2019-18660

Compile-tested on: none
Runtime-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/pending-4.9/161-mtd-part-add-generic-parsing-of-linux-part-probe.patch

index d939b09fb5ad1a7b2d739566de5465e8cb0e08b6..2f80a62e7e650ede70f6134a0fb1ec4382fa1e5a 100644 (file)
@@ -6,11 +6,11 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.9 = .202
+LINUX_VERSION-4.9 = .205
 LINUX_VERSION-4.14 = .156
 LINUX_VERSION-4.19 = .86
 
-LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
+LINUX_KERNEL_HASH-4.9.205 = 98b9e8644706acc0cf51022372bb263b59a1d2bbe3ccd7ce6bd9bc7378c78b05
 LINUX_KERNEL_HASH-4.14.156 = f8889feb0cbd7df36ff35bd4c72c1e2010567621bfcb218fcfa501bc5c7787c0
 LINUX_KERNEL_HASH-4.19.86 = bf2cbba319d43d1bd9e876ac0b55ab83118d1a1e61cce3c929d5371f7567bff6
 
index 4fd101db27b55ea5f5ca57ed7df6bc5191d4f0f6..6052bf5777360165ec09d042dbc36dbaa317dbac 100644 (file)
@@ -1150,7 +1150,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return work_done;
 --- a/drivers/net/ethernet/ti/cpsw.c
 +++ b/drivers/net/ethernet/ti/cpsw.c
-@@ -843,7 +843,7 @@ static int cpsw_rx_poll(struct napi_stru
+@@ -844,7 +844,7 @@ static int cpsw_rx_poll(struct napi_stru
        }
  
        if (num_rx < budget) {
@@ -1227,7 +1227,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        }
 --- a/drivers/net/ethernet/toshiba/tc35815.c
 +++ b/drivers/net/ethernet/toshiba/tc35815.c
-@@ -1639,7 +1639,7 @@ static int tc35815_poll(struct napi_stru
+@@ -1641,7 +1641,7 @@ static int tc35815_poll(struct napi_stru
        spin_unlock(&lp->rx_lock);
  
        if (received < budget) {
@@ -1346,7 +1346,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
 --- a/drivers/net/wireless/ath/ath10k/pci.c
 +++ b/drivers/net/wireless/ath/ath10k/pci.c
-@@ -2804,7 +2804,7 @@ static int ath10k_pci_napi_poll(struct n
+@@ -2803,7 +2803,7 @@ static int ath10k_pci_napi_poll(struct n
        done = ath10k_htt_txrx_compl_task(ar, budget);
  
        if (done < budget) {
index 1b6290fca25afccd8d0e36fb1ca4422a1b7070d5..64ed23170bb659208a5491ea5543242bb09d14d8 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  errors per {size} bytes".
 --- a/drivers/mtd/maps/physmap_of.c
 +++ b/drivers/mtd/maps/physmap_of.c
-@@ -113,47 +113,9 @@ static struct mtd_info *obsolete_probe(s
+@@ -104,47 +104,9 @@ static struct mtd_info *obsolete_probe(s
  static const char * const part_probe_types_def[] = {
        "cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL };
  
@@ -88,7 +88,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
        const struct of_device_id *match;
        struct device_node *dp = dev->dev.of_node;
        struct resource res;
-@@ -317,14 +279,8 @@ static int of_flash_probe(struct platfor
+@@ -300,14 +262,8 @@ static int of_flash_probe(struct platfor
  
        info->cmtd->dev.parent = &dev->dev;
        mtd_set_of_node(info->cmtd, dp);