kernel: bump 4.19 to 4.19.97
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 11:25:02 +0000 (12:25 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 20 Jan 2020 12:41:49 +0000 (13:41 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.19/950-0700-regulator-gpio-Allow-nonexclusive-GPIO-access.patch
target/linux/brcm2708/patches-4.19/950-0701-gpio-Enable-nonexclusive-gpiods-from-DT-nodes.patch

index 07d5efe8bbe1911aa798ab851d0c272f4ab124a9..c4186b8d3ea60ac0300b8a39a6de09ba3e1425e8 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-4.14 = .166
-LINUX_VERSION-4.19 = .96
+LINUX_VERSION-4.19 = .97
 
 LINUX_KERNEL_HASH-4.14.166 = 8bb2bf811a2092933a2386a4e679cd0c88de979c10fbb463d8142add4e577c00
-LINUX_KERNEL_HASH-4.19.96 = 23c1d1d5ba7bc14f9850e5ce78006712fe6c65dedcf67d3c99cec9c16a631d4d
+LINUX_KERNEL_HASH-4.19.97 = 8fb2a328e05e545274e721cf84baaf612b9330febc6f581b9ead81eaf41496da
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 6bcfab0ea9b06b0aa6380f68e208505353043829..a940736c3e235ca87f48471a267b57aeac1a9c46 100644 (file)
@@ -41,7 +41,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -3987,8 +3987,23 @@ struct gpio_desc *__must_check gpiod_get
+@@ -3988,8 +3988,23 @@ struct gpio_desc *__must_check gpiod_get
         * the device name as label
         */
        status = gpiod_request(desc, con_id ? con_id : devname);
index 8e79dae6af5709bf692f3a73432e141fc7194c58..a4139e6d384b280b98e10cbc70d60680341f024e 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Mark Brown <broonie@kernel.org>
 
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -4061,6 +4061,8 @@ struct gpio_desc *gpiod_get_from_of_node
+@@ -4062,6 +4062,8 @@ struct gpio_desc *gpiod_get_from_of_node
        transitory = flags & OF_GPIO_TRANSITORY;
  
        ret = gpiod_request(desc, label);