soloscli: fix uci-defaults file
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 6 Jun 2020 21:09:59 +0000 (23:09 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 10 Jun 2020 23:49:24 +0000 (01:49 +0200)
The folder for the uci-defaults file of this package is wrong, so
the file most probably has not been executed at all for several
years at least.

Fix the folder and remove the useless shebang for the file.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/network/config/soloscli/Makefile
package/network/config/soloscli/files/etc/uci-default/solos [deleted file]
package/network/config/soloscli/files/etc/uci-defaults/solos [new file with mode: 0644]

index 877a0f275b45fbd8c705753ed582e7c0e498b526..52a53dc0fa27f7a618c0134c649e4da4d9db890b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=soloscli
 PKG_VERSION:=1.04
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=solos-pci-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/openadsl
diff --git a/package/network/config/soloscli/files/etc/uci-default/solos b/package/network/config/soloscli/files/etc/uci-default/solos
deleted file mode 100644 (file)
index 7f69da6..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-uci batch <<__EOF__
-
-delete network.wan.solos0
-
-add_list network.wan.solos0="ActivateLine=Abort"
-add_list network.wan.solos0="Retrain=EnableAll"
-add_list network.wan.solos0="DetectNoise=Enable"
-add_list network.wan.solos0="BisMCapability=Disable"
-add_list network.wan.solos0="BisACapability=Disable"
-add_list network.wan.solos0="ActivateLine=Start"
-
-commit network
-__EOF__
diff --git a/package/network/config/soloscli/files/etc/uci-defaults/solos b/package/network/config/soloscli/files/etc/uci-defaults/solos
new file mode 100644 (file)
index 0000000..6645fc3
--- /dev/null
@@ -0,0 +1,13 @@
+uci batch <<__EOF__
+
+delete network.wan.solos0
+
+add_list network.wan.solos0="ActivateLine=Abort"
+add_list network.wan.solos0="Retrain=EnableAll"
+add_list network.wan.solos0="DetectNoise=Enable"
+add_list network.wan.solos0="BisMCapability=Disable"
+add_list network.wan.solos0="BisACapability=Disable"
+add_list network.wan.solos0="ActivateLine=Start"
+
+commit network
+__EOF__