build: enable gzipping of images on x86 even if ext4 is disabled
authorFelix Fietkau <nbd@nbd.name>
Mon, 27 Mar 2017 13:18:22 +0000 (15:18 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 6 Jul 2017 09:30:33 +0000 (11:30 +0200)
There is lots of padding between the boot partition and the rootfs, so
gzipping is helpful here

Signed-off-by: Felix Fietkau <nbd@nbd.name>
config/Config-images.in
target/linux/x86/image/Makefile

index 95752f737ad013a296afb5e7b28278a16b73b27d..55aff7d08757eeed704b1290ea2755189d571b1d 100644 (file)
@@ -242,7 +242,7 @@ menu "Target Images"
 
        config TARGET_IMAGES_GZIP
                bool "GZip images"
-               depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+               depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS || TARGET_x86
                default y
 
        comment "Image Options"
index ca5d0123c718f34d776ecd230ab84e83c63dde3d..d3005d79c3f2d7379dc2ee25786cf9a52ead116d 100644 (file)
@@ -153,11 +153,9 @@ ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
   define Image/Build/gzip/ext4
        $(call Image/Build/gzip,ext4)
   endef
-  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
-    define Image/Build/gzip/squashfs
+  define Image/Build/gzip/squashfs
        $(call Image/Build/gzip,squashfs)
-    endef
-  endif
+  endef
 endif
 
 define Image/BuildKernel