kirkwood: move sata features to modules
authorPawel Dembicki <paweldembicki@gmail.com>
Thu, 30 Apr 2020 10:18:24 +0000 (12:18 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Jun 2020 19:16:20 +0000 (21:16 +0200)
All devices are using nand images. Built-in SATA modules are not needed
anymore.

Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
[only move CONFIG_SATA_MV]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Tested-by: Pawel Dembicki <paweldembicki@gmail.com> [pogo v4]
target/linux/generic/config-4.14
target/linux/generic/config-4.19
target/linux/generic/config-5.4
target/linux/kirkwood/config-5.4
target/linux/kirkwood/image/Makefile

index 99e4075654c00f679471380a89ff8517cd9b916c..bcf47f10d1226edaa4817ad7fb961cc3ddd6a210 100644 (file)
@@ -350,6 +350,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
index 7e530f347f897b9fef3fa23905c9ba4b68a78dfd..aa0b0e0b200b37f1d309dc980774e5793621f724 100644 (file)
@@ -359,6 +359,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
index ea4e9a5d3f69735b0bee45165f4f314b0b92e876..aca72b8fae1d565488ed736ef8f584432df2143f 100644 (file)
@@ -399,6 +399,7 @@ CONFIG_ATAGS_PROC=y
 # CONFIG_ATA_ACPI is not set
 CONFIG_ATA_BMDMA=y
 # CONFIG_ATA_GENERIC is not set
+# CONFIG_ATA_LEDS is not set
 # CONFIG_ATA_NONSTANDARD is not set
 # CONFIG_ATA_OVER_ETH is not set
 # CONFIG_ATA_PIIX is not set
index c14ca3778f37c05ad205a827acb53cfd148be26d..4be83a51396a6d525df44b06f77cf1ce1e3b2fac 100644 (file)
@@ -305,7 +305,6 @@ CONFIG_REGULATOR_FIXED_VOLTAGE=y
 CONFIG_RTC_CLASS=y
 CONFIG_RTC_DRV_MV=y
 CONFIG_RTC_I2C_AND_SPI=y
-CONFIG_SATA_MV=y
 CONFIG_SATA_PMP=y
 CONFIG_SCSI=y
 CONFIG_SERIAL_8250_DEPRECATED_OPTIONS=y
index 552ee44ee44d116767262de67f1628abf106e91e..76dfc4ea09bc4bc8ffdf4203edabdd577a4da6ec 100644 (file)
@@ -50,7 +50,7 @@ define Device/cloudengines_pogoplugv4
   DEVICE_VENDOR := Cloud Engines
   DEVICE_MODEL := Pogoplug V4
   DEVICE_DTS := kirkwood-pogoplug-series-4
-  DEVICE_PACKAGES := kmod-usb3
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-usb3
 endef
 TARGET_DEVICES += cloudengines_pogoplugv4
 
@@ -65,7 +65,8 @@ define Device/iom_ix2-200
   DEVICE_VENDOR := Iomega
   DEVICE_MODEL := StorCenter ix2-200
   DEVICE_DTS := kirkwood-iomega_ix2_200
-  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-lm63
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+       kmod-hwmon-lm63
   PAGESIZE := 512
   SUBPAGESIZE := 256
   BLOCKSIZE := 16k
@@ -110,6 +111,7 @@ define Device/raidsonic_ib-nas62x0
   DEVICE_VENDOR := RaidSonic
   DEVICE_MODEL := ICY BOX IB-NAS62x0
   BOARD_NAME := ib62x0
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += raidsonic_ib-nas62x0
 
@@ -124,6 +126,7 @@ define Device/seagate_goflexnet
   DEVICE_VENDOR := Seagate
   DEVICE_MODEL := GoFlexNet
   BOARD_NAME := goflexnet
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += seagate_goflexnet
 
@@ -131,13 +134,15 @@ define Device/seagate_goflexhome
   DEVICE_VENDOR := Seagate
   DEVICE_MODEL := GoFlexHome
   BOARD_NAME := goflexhome
+  DEVICE_PACKAGES := kmod-ata-marvell-sata
 endef
 TARGET_DEVICES += seagate_goflexhome
 
 define Device/zyxel_nsa310b
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA310b
-  DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-r8169 \
+       kmod-gpio-button-hotplug kmod-hwmon-lm85
   BOARD_NAME := nsa310b
 endef
 TARGET_DEVICES += zyxel_nsa310b
@@ -146,7 +151,8 @@ define Device/zyxel_nsa325
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NSA325
   DEVICE_VARIANT := v1/v2
-  DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
+  DEVICE_PACKAGES := kmod-ata-marvell-sata kmod-gpio-button-hotplug \
+       kmod-rtc-pcf8563 kmod-usb3
   BOARD_NAME := nsa325
 endef
 TARGET_DEVICES += zyxel_nsa325