package/lldp: don't link against libbsd on !USE_GLIBC builds
authorAlexander Couzens <lynxis@fe80.eu>
Tue, 4 Sep 2018 01:10:24 +0000 (03:10 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 4 Oct 2018 22:44:55 +0000 (00:44 +0200)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/network/services/lldpd/Makefile

index 3605ed25f9232e3166205453c876eabfbacc3dd1..97ae23e1d97511e216a95477b6bcfd31b10d057a 100644 (file)
@@ -111,5 +111,8 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no) \
        $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,)
 
+# there is no flag to disable libbsd
+CONFIGURE_VARS += \
+       $(if $(CONFIG_USE_GLIBC),,libbsd_LIBS="-lNONexistent")
 
 $(eval $(call BuildPackage,lldpd))