Revert "build: add option to warn on recursive dependency"
authorJo-Philipp Wich <jo@mein.io>
Sat, 11 Apr 2020 22:09:46 +0000 (00:09 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sat, 11 Apr 2020 22:10:30 +0000 (00:10 +0200)
This reverts commit 3204430e38f1a2ba7fda9471720a2a1042adf5e0.

Reverting this commit in preparation for reverting
dcf3e63a35 ("build: scripts/config - update to kconfig-v5.6") which
introduces various unaddressed build breakages.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/toplevel.mk
scripts/config/README
scripts/config/symbol.c

index def80503dd911d209d55bfa7a79fc3dd83f79d1c..2965f75c7cd7e66fef5b7562a77f134ff6ddb18f 100644 (file)
@@ -102,7 +102,7 @@ prepare-tmpinfo: FORCE
 ifneq ($(DISTRO_PKG_CONFIG),)
 scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
 endif
-scripts/config/%onf: CFLAGS+= -O2 $(if $(WARN_RECURSIVE_DEP),-DWARN_RECURSIVE_DEP)
+scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
        @$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
 
index 81243e8016dd888c3e80c67262d625bde701e3ce..ac5f094ff2933971a781acb78fa5f874778247c0 100644 (file)
@@ -16,10 +16,6 @@ OpenWrt Buildroot:
  - reverted an upstream change that avoids writing symbols that are not
    visible to .config, which breaks OpenWrt busybox's '.config' generation
    logic.
- - add a compilation option (-DWARN_RECURSIVE_DEP) to treat recursive deps
-   as a warning, avoiding a complete build failure because of unrelated or
-   minor recursive deps, or making a scrict check before commiting a change
-   that may cause one.
  - use pre-built *.lex.c *.tab.[ch] files by default, to avoid depending on
    flex & bison.  Rebuild/remove these files only if running make with
    BUILD_SHIPPED_FILES defined
index 5c6f54031437a0d64b98ac6942d6892550c0b753..b1dd9be29d541217c931c61492810326e2e82d68 100644 (file)
@@ -1250,11 +1250,6 @@ struct symbol *sym_check_deps(struct symbol *sym)
                sym->flags &= ~SYMBOL_CHECK;
        }
 
-#ifdef WARN_RECURSIVE_DEP
-       if (sym2 && sym2 == sym)
-               sym2 = NULL;
-#endif
-
        return sym2;
 }