treewide: drop DEVICE_TYPE when used as device variable
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 29 May 2020 15:58:20 +0000 (17:58 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jun 2020 13:41:09 +0000 (15:41 +0200)
DEVICE_TYPE is a target/subtarget variable, and it does not have
any effect when set in a device definition. It can only be set
in a target's or subtarget's Makefile.

Consequently, having it set anyway is misleading, so this drops
all cases.

This effectively reverts the following commits:
7a1497fd601d ("apm821xx: MBL: set DEVICE_TYPE to NAS")
5b4765c93a1b ("gemini: Classify Raidsonic NAS IB-4220-B as a NAS")
cdc6de460bb4 ("gemini: D-Link DNS-313 is a NAS")

For the following commit, the variable was set when adding device
support:
27b2f0fc0fc5 ("kirkwood: add support for Iomega Storcenter ix2-200")

Cc: Christian Lamparter <chunkeey@gmail.com>
Cc: Sungbo Eo <mans0n@gorani.run>
Cc: Linus Walleij <linus.walleij@linaro.org>
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/apm821xx/image/Makefile
target/linux/gemini/image/Makefile
target/linux/kirkwood/image/Makefile

index d732141c8f88b72aa2705c8292853b1d47a78a42..c26c015751f553823a45af3b80ae1ac7b5b170a6 100644 (file)
@@ -230,7 +230,6 @@ define Device/wd_mybooklive
   DEVICE_VENDOR := Western Digital
   DEVICE_MODEL := My Book Live Series (Single + Duo)
   DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-usb-storage kmod-fs-vfat wpad-basic
-  DEVICE_TYPE := nas
   DEVICE_DTS := wd-mybooklive
   SUPPORTED_DEVICES += mbl wd,mybooklive-duo
   BLOCKSIZE := 1k
index a155939b8cd65387b9730311ea2affa58f21d8fa..83f3d222d98b1a6843b7bbb079b12ce0f95f64b4 100644 (file)
@@ -171,7 +171,6 @@ define Device/dlink_dns-313
        DEVICE_VENDOR := D-Link
        DEVICE_MODEL := DNS-313 1-Bay Network Storage Enclosure
        DEVICE_DTS := gemini-dlink-dns-313
-       DEVICE_TYPE := nas
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
        BLOCKSIZE := 1k
        FILESYSTEMS := ext4
@@ -204,7 +203,6 @@ define Device/raidsonic_ib-4220-b
        DEVICE_VENDOR := Raidsonic
        DEVICE_MODEL := NAS IB-4220-B
        DEVICE_DTS := gemini-nas4220b
-       DEVICE_TYPE := nas
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b
 
index e69e3f125d013f804de66b3b7e97d32fe501fab1..552ee44ee44d116767262de67f1628abf106e91e 100644 (file)
@@ -66,7 +66,6 @@ define Device/iom_ix2-200
   DEVICE_MODEL := StorCenter ix2-200
   DEVICE_DTS := kirkwood-iomega_ix2_200
   DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-hwmon-lm63
-  DEVICE_TYPE:=nas
   PAGESIZE := 512
   SUBPAGESIZE := 256
   BLOCKSIZE := 16k