add a "make prepare" target which builds everything up to target/compile, useful...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 28 May 2009 18:40:37 +0000 (18:40 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 28 May 2009 18:40:37 +0000 (18:40 +0000)
SVN-Revision: 16153

Makefile

index 6cf4a4b1e0ebe4de6e82591d248ee9e5538ccca1..db79274c9af0e2f1b9666841a780fb5bc154854f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,6 +48,8 @@ $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
        @touch $@
 
+prepare: $(target/stamp-compile)
+
 clean: FORCE
        $(_SINGLE)$(SUBMAKE) target/linux/clean
        rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)