build: fix kernel_menuconfig on macOS with newer kernel versions
authorFelix Fietkau <nbd@nbd.name>
Tue, 7 Apr 2020 12:26:42 +0000 (14:26 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 9 Apr 2020 07:54:02 +0000 (09:54 +0200)
Account for upstream build system changes

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel-build.mk

index b1d3fc07fd233503901af2cb47f1125f5ee1c29c..c371e78ab9b0b63bdd4de77cfa426ce0d3afbf9b 100644 (file)
@@ -162,7 +162,11 @@ define BuildKernel
        rm -f $(STAMP_CONFIGURED)
        $(LINUX_RECONF_CMD) > $(LINUX_DIR)/.config
        $(_SINGLE)$(KERNEL_MAKE) \
-               $(if $(findstring Darwin,$(HOST_OS)),HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses") \
+               $(if $(findstring Darwin,$(HOST_OS)), \
+                       HOST_LOADLIBES="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+                       HOSTLDLIBS_mconf="-L$(STAGING_DIR_HOST)/lib -lncurses" \
+                       filechk_conf_cfg="      :" \
+               ) \
                YACC=$(STAGING_DIR_HOST)/bin/bison \
                $$@
        $(LINUX_RECONF_DIFF) $(LINUX_DIR)/.config | \