buildsystem: add CPE information to ipkg packages and manifest files
authorFlorian Eckert <fe@dev.tdt.de>
Sun, 16 Dec 2018 20:30:20 +0000 (21:30 +0100)
committerJo-Philipp Wich <jo@mein.io>
Tue, 5 May 2020 20:07:59 +0000 (22:07 +0200)
Common Platform Enumeration (CPE) is a structured naming scheme for
information technology systems, software, and packages.

This information already exists in some makefiles. In order for the
information to be processed further, it should also be added to the
manifest file and the control file of ipkg packages.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
include/package-ipkg.mk

index c4c8f4a36feb613ea4065099e55f624970127737..569edcbf0363275e20ae5efd2b2cac676d9a34af 100644 (file)
@@ -173,6 +173,7 @@ $$(call addfield,Depends,$$(Package/$(1)/DEPENDS)
 )$$(call addfield,LicenseFiles,$(LICENSE_FILES)
 )$$(call addfield,Section,$(SECTION)
 )$$(call addfield,Require-User,$(USERID)
+)$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
 )$(if $(filter hold,$(PKG_FLAGS)),Status: unknown hold not-installed
 )$(if $(filter essential,$(PKG_FLAGS)),Essential: yes
 )$(if $(MAINTAINER),Maintainer: $(MAINTAINER)