kernel: properly insert local mtd partition parsers
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 25 May 2020 16:08:25 +0000 (18:08 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 25 May 2020 19:11:47 +0000 (21:11 +0200)
Between 4.19 and 5.4, the kernel moved the partition parsers into
the parsers subdirectory. This led to some necessary rebasing of
our local patches for parsers, which partially has been performed
without caring about where the code was inserted.

This commit tries to adjust our local patches so that parsers are
inserted at the "proper" positions with respect to alphabetic sorting
(if possible). Thus, the commit is cosmetic.

While this might look useless now, it will make life easier when
adding other parsers in the future or for rebasing on kernel changes.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
target/linux/generic/pending-5.4/430-mtd-add-myloader-partition-parser.patch
target/linux/generic/pending-5.4/435-mtd-add-routerbootpart-parser-config.patch
target/linux/ipq806x/patches-5.4/0031-mtd-add-SMEM-parser-for-QCOM-platforms.patch

index c26ef60725c0a66321f83659376576e1575d38b4..1ebf87c61045aea1a54460f4539d538329bbe24a 100644 (file)
@@ -1,15 +1,18 @@
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -1,3 +1,4 @@
+@@ -5,6 +5,7 @@ obj-$(CONFIG_MTD_BCM63XX_PARTS)                += bcm6
+ obj-$(CONFIG_MTD_CMDLINE_PARTS)               += cmdlinepart.o
+ obj-$(CONFIG_MTD_MYLOADER_PARTS)              += myloader.o
+ obj-$(CONFIG_MTD_OF_PARTS)            += ofpart.o
 +obj-$(CONFIG_MTD_PARSER_CYBERTAN)     += parser_cybertan.o
- # SPDX-License-Identifier: GPL-2.0-only
- obj-$(CONFIG_MTD_AR7_PARTS)           += ar7part.o
- obj-$(CONFIG_MTD_BCM47XX_PARTS)               += bcm47xxpart.o
+ obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
+ obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -94,6 +94,14 @@ config MTD_AFS_PARTS
-         for your particular device. It won't happen automatically. The
-         'physmap' map driver (CONFIG_MTD_PHYSMAP) does this, for example.
+@@ -83,6 +83,14 @@ config MTD_OF_PARTS
+         flash memory node, as described in
+         Documentation/devicetree/bindings/mtd/partition.txt.
  
 +config MTD_PARSER_CYBERTAN
 +      tristate "Parser for Cybertan format partitions"
@@ -19,6 +22,6 @@
 +        header. This driver will parse the header and take care of the
 +        special offsets that result in the extra headers.
 +
- config MTD_PARSER_TRX
-       tristate "Parser for TRX format partitions"
-       depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)
+ config MTD_PARSER_IMAGETAG
+       tristate "Parser for BCM963XX Image Tag format partitions"
+       depends on BCM63XX || BMIPS_GENERIC || COMPILE_TEST
index 2fd24a420c796f00a36f637be83539786ce8d1f4..9600dfc67acf1a48d595a6585a1e04e63b3a1172 100644 (file)
@@ -10,11 +10,10 @@ Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -160,3 +160,19 @@ config MTD_REDBOOT_PARTS_READONLY
-         'FIS directory' images, enable this option.
+@@ -57,6 +57,22 @@ config MTD_CMDLINE_PARTS
+         If unsure, say 'N'.
  
- endif # MTD_REDBOOT_PARTS
-+
 +config MTD_MYLOADER_PARTS
 +      tristate "MyLoader partition parsing"
 +      depends on ADM5120 || ATH25 || ATH79
@@ -30,13 +29,20 @@ Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
 +
 +        You will still need the parsing functions to be called by the driver
 +        for your particular device. It won't happen automatically.
++
+ config MTD_OF_PARTS
+       tristate "OpenFirmware (device tree) partitioning parser"
+       default y
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -9,3 +9,4 @@ obj-$(CONFIG_MTD_AFS_PARTS)            += afs.o
- obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
- obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
+@@ -3,6 +3,7 @@ obj-$(CONFIG_MTD_AR7_PARTS)            += ar7part.
+ obj-$(CONFIG_MTD_BCM47XX_PARTS)               += bcm47xxpart.o
+ obj-$(CONFIG_MTD_BCM63XX_PARTS)               += bcm63xxpart.o
+ obj-$(CONFIG_MTD_CMDLINE_PARTS)               += cmdlinepart.o
 +obj-$(CONFIG_MTD_MYLOADER_PARTS)              += myloader.o
+ obj-$(CONFIG_MTD_OF_PARTS)            += ofpart.o
+ obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
+ obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
 --- /dev/null
 +++ b/drivers/mtd/parsers/myloader.c
 @@ -0,0 +1,181 @@
index 4e72aa88a00e92931b52322f0c6864d02dca65b1..1523e757c70aca723bd80d11d4c5bf3f50d48b02 100644 (file)
@@ -16,10 +16,10 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -176,3 +176,12 @@ config MTD_MYLOADER_PARTS
+@@ -176,3 +176,12 @@ config MTD_REDBOOT_PARTS_READONLY
+         'FIS directory' images, enable this option.
  
-         You will still need the parsing functions to be called by the driver
-         for your particular device. It won't happen automatically.
+ endif # MTD_REDBOOT_PARTS
 +
 +config MTD_ROUTERBOOT_PARTS
 +      tristate "RouterBoot flash partition parser"
@@ -31,10 +31,8 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 +       formatted DTS.
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -9,4 +9,5 @@ obj-$(CONFIG_MTD_AFS_PARTS)            += afs.o
+@@ -10,3 +10,4 @@ obj-$(CONFIG_MTD_AFS_PARTS)          += afs.o
  obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
--obj-$(CONFIG_MTD_MYLOADER_PARTS)              += myloader.o
-+obj-$(CONFIG_MTD_MYLOADER_PARTS)      += myloader.o
-+obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)    += routerbootpart.o
++obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)            += routerbootpart.o
index e19ad5277e52ce61ca1e4b4663763874d299857e..6aa404c8c5a37ad7adbf12af3ec12d8010a80b1b 100644 (file)
@@ -18,9 +18,9 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -20,6 +20,13 @@ config MTD_BCM63XX_PARTS
-         This provides partition parsing for BCM63xx devices with CFE
-         bootloaders.
+@@ -119,6 +119,13 @@ config MTD_PARSER_TRX
+         This driver will parse TRX header and report at least two partitions:
+         kernel and rootfs.
  
 +config MTD_QCOM_SMEM_PARTS
 +      tristate "QCOM SMEM partitioning support"
@@ -29,9 +29,19 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
 +        This provides partitions parser for QCOM devices using SMEM
 +        such as IPQ806x.
 +
- config MTD_CMDLINE_PARTS
-       tristate "Command line partition table parsing"
-       depends on MTD
+ config MTD_SHARPSL_PARTS
+       tristate "Sharp SL Series NAND flash partition parser"
+       depends on MTD_NAND_SHARPSL || MTD_NAND_TMIO || COMPILE_TEST
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MTD_OF_PARTS)             += ofpart.o
+ obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
+ obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o
+ obj-$(CONFIG_MTD_PARSER_TRX)          += parser_trx.o
++obj-$(CONFIG_MTD_QCOM_SMEM_PARTS)             += qcom_smem_part.o
+ obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o
+ obj-$(CONFIG_MTD_ROUTERBOOT_PARTS)            += routerbootpart.o
 --- /dev/null
 +++ b/drivers/mtd/parsers/qcom_smem_part.c
 @@ -0,0 +1,235 @@
@@ -270,13 +280,3 @@ Signed-off-by: Ram Chandra Jangir <rjangi@codeaurora.org>
 +MODULE_LICENSE("GPL");
 +MODULE_AUTHOR("Mathieu Olivari <mathieu@codeaurora.org>");
 +MODULE_DESCRIPTION("Parsing code for SMEM based partition tables");
---- a/drivers/mtd/parsers/Makefile
-+++ b/drivers/mtd/parsers/Makefile
-@@ -3,6 +3,7 @@ obj-$(CONFIG_MTD_AR7_PARTS)            += ar7part.
- obj-$(CONFIG_MTD_BCM47XX_PARTS)               += bcm47xxpart.o
- obj-$(CONFIG_MTD_BCM63XX_PARTS)               += bcm63xxpart.o
- obj-$(CONFIG_MTD_CMDLINE_PARTS)               += cmdlinepart.o
-+obj-$(CONFIG_MTD_QCOM_SMEM_PARTS) += qcom_smem_part.o
- obj-$(CONFIG_MTD_OF_PARTS)            += ofpart.o
- obj-$(CONFIG_MTD_PARSER_IMAGETAG)     += parser_imagetag.o
- obj-$(CONFIG_MTD_AFS_PARTS)           += afs.o