odhcpd: remove bogus IPKG_INSTROOT reference
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 10 Jun 2020 16:27:27 +0000 (17:27 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 11 Jun 2020 14:46:55 +0000 (15:46 +0100)
IPKG_INSTROOT is only set under image builder and we won't be running
this script at build time either, so remove the reference before it gets
cargo-culted into other scripts.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Acked-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/odhcpd/Makefile
package/network/services/odhcpd/files/odhcpd-update

index 6510ce6c805a3fb68f875e90e88647e714c5a647..07d7d7d6730d80c294fa2fea4d3647ae7812fc77 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcpd
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/odhcpd.git
index 9bc7abcc1c3a85c77a3e8b791393768f7afec570..c1814e00b049c5cca1e94dd206d8f465ed2b4270 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 # Make dnsmasq reread hostfile by sending SIGHUP signal
 
-. $IPKG_INSTROOT/lib/functions/procd.sh
+. /lib/functions/procd.sh
 
 procd_send_signal dnsmasq