hostapd: add config symbol for allowing drivers to enable 802.11ax support
authorFelix Fietkau <nbd@nbd.name>
Sun, 7 Jun 2020 19:15:54 +0000 (21:15 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 10 Jun 2020 10:56:35 +0000 (12:56 +0200)
Also expose a build feature for it

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile
package/network/services/hostapd/src/src/utils/build_features.h

index 2cdd1ed9701b1adda2c18101fa40cafbd3ec62a1..81a374c6525ad0d4b8bf2fd54312a9871fe3dd46 100644 (file)
@@ -70,6 +70,10 @@ config DRIVER_11AC_SUPPORT
        bool
        default n
 
+config DRIVER_11AX_SUPPORT
+       bool
+       default n
+
 config DRIVER_11W_SUPPORT
        bool
        default n
index ea90e01c1d632f39a85b612179794ce68b82ae85..d754f19857ea0c519e54d4bc3a30c5267eb97939 100644 (file)
@@ -32,6 +32,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DRIVER_WEXT_SUPPORT \
        CONFIG_DRIVER_11N_SUPPORT \
        CONFIG_DRIVER_11AC_SUPPORT \
+       CONFIG_DRIVER_11AX_SUPPORT \
        CONFIG_WPA_ENABLE_WEP
 
 EAPOL_TEST_PROVIDERS:=eapol-test eapol-test-openssl eapol-test-wolfssl
@@ -81,11 +82,16 @@ ifneq ($(CONFIG_DRIVER_11AC_SUPPORT),)
   HOSTAPD_IEEE80211AC:=y
 endif
 
+ifneq ($(CONFIG_DRIVER_11AX_SUPPORT),)
+  HOSTAPD_IEEE80211AX:=y
+endif
+
 DRIVER_MAKEOPTS= \
        CONFIG_ACS=$(CONFIG_PACKAGE_kmod-cfg80211) \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-cfg80211) \
        CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
+       CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
 ifneq ($(LOCAL_VARIANT),mini)
index b28ff6fa9f548dfffcc9166911861bdb943c97d7..35356b2323a80cf2c28ef80435a2114f791d1200 100644 (file)
@@ -15,6 +15,10 @@ static inline int has_feature(const char *feat)
        if (!strcmp(feat, "11ac"))
                return 1;
 #endif
+#ifdef CONFIG_IEEE80211AX
+       if (!strcmp(feat, "11ax"))
+               return 1;
+#endif
 #ifdef CONFIG_IEEE80211R
        if (!strcmp(feat, "11r"))
                return 1;