ipq40xx: check kernel-size for NBG6617
authorDavid Bauer <mail@david-bauer.net>
Sun, 14 Jun 2020 11:10:00 +0000 (13:10 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 14 Jun 2020 11:10:00 +0000 (13:10 +0200)
The ZyXEL NBG6617 has a separate kernel partition which is 4MiB large.

Add the kernel size to validate the kernel won't be bigger than this
fixed limit.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ipq40xx/image/Makefile

index 51849e06f67169d8daad92ebb8da5ec8ffc9f8b6..632836e94fab07d010fb64bc00f01102e2f60703 100644 (file)
@@ -661,6 +661,7 @@ define Device/zyxel_nbg6617
        DEVICE_VENDOR := ZyXEL
        DEVICE_MODEL := NBG6617
        SOC := qcom-ipq4018
+       KERNEL_SIZE := 4096k
        ROOTFS_SIZE := 24960k
        RAS_BOARD := NBG6617
        RAS_ROOTFS_SIZE := 19840k