build: rename .packagesubdirs to .packageauxvars
authorJo-Philipp Wich <jo@mein.io>
Fri, 18 Jan 2019 11:32:57 +0000 (12:32 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sat, 19 Jan 2019 13:31:56 +0000 (14:31 +0100)
Subsequent commits will put more auxiliary information into this file,
such as the per-package ABI version, so rename the metadata script
subcommand and file names accordingly.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/feeds.mk
include/toplevel.mk
scripts/package-metadata.pl

index d20cdfe0690e0f2cd36755d7f32efd0f1c22809d..a908a5720a232b4b0d0f65b304a0e004f91256cb 100644 (file)
@@ -6,7 +6,7 @@
 # See /LICENSE for more information.
 #
 
--include $(TMP_DIR)/.packagesubdirs
+-include $(TMP_DIR)/.packageauxvars
 
 FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
 FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
index b57dcd8544f603e360336b84e5eb5187bff9a6ff..36f790f8072a5fb9bf3f6f15adf26ca3e6896f43 100644 (file)
@@ -88,9 +88,9 @@ prepare-tmpinfo: FORCE
                f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
                [ "$$t" -nt "$$f" ] || ./scripts/$${type}-metadata.pl $(_ignore) config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
        done
-       [ tmp/.config-feeds.in -nt tmp/.packagesubdirs ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
+       [ tmp/.config-feeds.in -nt tmp/.packageauxvars ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
        ./scripts/package-metadata.pl mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
-       ./scripts/package-metadata.pl subdirs tmp/.packageinfo > tmp/.packagesubdirs || { rm -f tmp/.packagesubdirs; false; }
+       ./scripts/package-metadata.pl pkgaux tmp/.packageinfo > tmp/.packageauxvars || { rm -f tmp/.packageauxvars; false; }
        touch $(TOPDIR)/tmp/.build
 
 .config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)
index 53bb45a62c83d628e62dc3857eb8d9d48d3b9ba3..b8c5de298a3ec1b0fac7227727f10b60a904d27f 100755 (executable)
@@ -509,7 +509,7 @@ sub gen_package_source() {
        }
 }
 
-sub gen_package_subdirs() {
+sub gen_package_auxiliary() {
        parse_package_metadata($ARGV[0]) or exit 1;
        foreach my $name (sort {uc($a) cmp uc($b)} keys %package) {
                my $pkg = $package{$name};
@@ -565,7 +565,7 @@ sub parse_command() {
                /^config$/ and return gen_package_config();
                /^kconfig/ and return gen_kconfig_overrides();
                /^source$/ and return gen_package_source();
-               /^subdirs$/ and return gen_package_subdirs();
+               /^pkgaux$/ and return gen_package_auxiliary();
                /^license$/ and return gen_package_license(0);
                /^licensefull$/ and return gen_package_license(1);
                /^usergroup$/ and return gen_usergroup_list();
@@ -577,7 +577,7 @@ Available Commands:
        $0 config [file]                        Package metadata in Kconfig format
        $0 kconfig [file] [config] [patchver]   Kernel config overrides
        $0 source [file]                        Package source file information
-       $0 subdirs [file]                       Package subdir information in makefile format
+       $0 pkgaux [file]                        Package auxiliary variables in makefile format
        $0 license [file]                       Package license information
        $0 licensefull [file]                   Package license information (full list)
        $0 usergroup [file]                     Package usergroup allocation list