scripts: fixup qemustart for new x86 image names
authorPaul Spooren <mail@aparcar.org>
Fri, 20 Mar 2020 10:10:59 +0000 (00:10 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 21 Mar 2020 10:36:00 +0000 (10:36 +0000)
qemustart allows easy testing of created images via `qemu`. The script
automatically selects created images and can setup e.g. networks.

As the x86 target now uses the generic image.mk the profile appears also
in the image name, this is *generic*.

Add the profile name to the qemustart script so it still finds the file.

Signed-off-by: Paul Spooren <mail@aparcar.org>
scripts/qemustart

index dbb8deddafd8093887d6dfcd37d5743a5e1ba48a..9ce03901aac2d5068542ec83670d2fcb5ee749b2 100755 (executable)
@@ -255,7 +255,7 @@ start_qemu_x86() {
        local mach="${o_mach:-pc}"
 
        [ -n "$rootfs" ] || {
-               rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-combined-ext4.img"
+               rootfs="$o_bindir/openwrt-$o_target-${o_subtarget%-*}-generic-ext4-combined.img"
                if [ ! -f "$rootfs" -a -s "$rootfs.gz" ]; then
                        gunzip "$rootfs.gz"
                fi