build: always run package/cleanup before package/compile
authorFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 12:30:39 +0000 (13:30 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 12:31:54 +0000 (13:31 +0100)
Remove unnecessary stampfile indirection
Fixes an issue with the command sequence used by buildbot

Signed-off-by: Felix Fietkau <nbd@nbd.name>
Makefile
package/Makefile

index a26eeee0a8b8727581ceae2be2a603702a0c2468..648fef5b865852773e564cc95ae6dd9470bc6466 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -41,7 +41,7 @@ else
 
 $(toolchain/stamp-compile): $(tools/stamp-compile)
 $(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-compile): $(target/stamp-compile)
 $(package/stamp-install): $(package/stamp-compile)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
 check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check)
index 6929c479a29144573073154c1d93e90d97198aa4..b5e4bfa12bc52e82d8e1f972473b3a066ea48ac8 100644 (file)
@@ -49,6 +49,8 @@ PACKAGE_INSTALL_FILES:= \
 $(curdir)/cleanup: $(TMP_DIR)/.build
        rm -rf $(STAGING_DIR_ROOT)
 
+$(curdir)/compile: $(curdir)/cleanup
+
 $(curdir)/merge:
        rm -rf $(PACKAGE_DIR_ALL)
        mkdir -p $(PACKAGE_DIR_ALL)
@@ -98,7 +100,6 @@ $(curdir)/preconfig:
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
 $(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build))