bcm63xx: image: don't add the CFE to the sercomm factory
authorDaniel González Cabanelas <dgcbueu@gmail.com>
Sun, 7 Jun 2020 08:55:51 +0000 (10:55 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 7 Jun 2020 18:26:17 +0000 (20:26 +0200)
There is no need to include the CFE bootloader in the Sercomm factory
images.

There might be a case when this could be useful:
  - We are running the stock firmware on the first Sercomm image
  - The second partition storing the botloader was erased (unlikely)
Even in this case flashing an image without a bootlader is harmless.

Don't include the bootloader in the factory image creation and rid of the
risk of flashing factory images with an untested bootloader partition.

Signed-off-by: Daniel González Cabanelas <dgcbueu@gmail.com>
target/linux/bcm63xx/image/Makefile

index c962e531a9d47c577ce1f66b126b26e8fdc704e2..294db6eb32d81df3f3555b88db1fcf2ab62cf2ee 100644 (file)
@@ -218,20 +218,8 @@ define Build/cfe-sercomm-part
                --part-name rootfs_lib \
                --part-version $(SERCOMM_VERSION)
 
-       rm -rf $@-bootloader
-       mkdir -p $@-bootloader
-       cp $(KDIR)/bcm63xx-cfe/$(CFE_RAM_FILE) $@-bootloader/$(CFE_RAM_JFFS2_NAME)
-       $(call Build/cfe-jffs2,$@-bootloader)
-       $(call Build/pad-to,$(BLOCKSIZE))
-       $(TOPDIR)/scripts/sercomm-partition-tag.py \
-               --input-file $@ \
-               --output-file $@.bootloader \
-               --part-name bootloader \
-               --part-version $(SERCOMM_VERSION)
-
        mv $@.kernel_rootfs $@
        dd if=$@.rootfs_lib >> $@
-       dd if=$@.bootloader >> $@
 endef
 
 define Build/cfe-sercomm-load