rules.mk: export STAGING_DIR_HOST to sub-makefiles and shells
authorFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 12:52:07 +0000 (12:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 7 Nov 2015 12:52:07 +0000 (12:52 +0000)
Certains host packages (like quilt) need to know the previously used
install location at run-time. They currently use $STAGING_DIR, which
causes issues on cleaned environment, where $STAGING_DIR doesn't exist
yet.

Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org>
SVN-Revision: 47409

rules.mk

index 7710fb4d9dfcae3d5a3874f4cfe39edd3258a957..348b45d6e19eea2036f29c13af3a2a6c8ba31e65 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -188,7 +188,7 @@ else
 endif
 
 export PATH:=$(TARGET_PATH)
-export STAGING_DIR
+export STAGING_DIR STAGING_DIR_HOST
 export SH_FUNC:=. $(INCLUDE_DIR)/shell.sh;
 
 PKG_CONFIG:=$(STAGING_DIR_HOST)/bin/pkg-config