toolchain/kernel-headers: don't use TARGET_CFLAGS
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Sat, 12 Oct 2019 07:41:41 +0000 (08:41 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 16 Oct 2019 15:10:38 +0000 (16:10 +0100)
Kernel utilities (e.g. scripts/kconfig/conf) are being built to run on
the host system at this stage, therefore it makes no sense to use the
target system CC flags.  Use HOSTCFLAGS instead

While we're here rename KMAKE macro to HOST_KMAKE to make it even more
obvious that we're building for host.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
toolchain/kernel-headers/Makefile

index f7842cb9bd8b8659da305928519850c27b2e0bf6..a4120d587dbfcffb1e9d7cb6cf17a048571a7c77 100644 (file)
@@ -41,14 +41,14 @@ HOST_EXTRACFLAGS=
 
 LINUX_HAS_HEADERS_INSTALL:=y
 
-KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
+HOST_KMAKE := $(MAKE) -C $(HOST_BUILD_DIR) \
        $(KERNEL_MAKE_FLAGS) \
        CC="$(KERNEL_CC)" \
-       CFLAGS="$(TARGET_CFLAGS)"
+       HOSTCFLAGS="$(HOST_CFLAGS)"
 
 define Host/Configure/all
        mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev
-       $(KMAKE) \
+       $(HOST_KMAKE) \
                INSTALL_HDR_PATH="$(BUILD_DIR_TOOLCHAIN)/linux-dev/" \
                headers_install
 endef
@@ -82,7 +82,7 @@ endef
 
 define Host/Configure
        env
-       yes '' | $(KMAKE) oldconfig
+       yes '' | $(HOST_KMAKE) oldconfig
        $(call Host/Configure/all)
        $(call Host/Configure/post/$(ARCH))
 endef