Config.in: add more options when it comes to including kernel image into rootfs
authorLuka Perkov <luka@openwrt.org>
Wed, 23 Oct 2013 22:16:10 +0000 (22:16 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 23 Oct 2013 22:16:10 +0000 (22:16 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38517

Config.in

index a7ef477b200091b13079253b52a352f784312e9d..38d11eb28170c29bf50d9a2eb3224bba10c80fc6 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -173,7 +173,7 @@ menu "Target Images"
                help
                  Allows you to change the percentage of reserved blocks in the root filesystem
 
-       config TARGET_ROOTFS_INCLUDE_KERNEL
+       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
                bool "Include kernel in root filesystem"
                depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
                default n if USES_UBIFS
@@ -181,6 +181,30 @@ menu "Target Images"
                  Include the kernel image in the rootfs. Typically the image is placed
                  below /boot.
 
+               config TARGET_ROOTFS_INCLUDE_UIMAGE
+                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+                       default y
+                       help
+                         This option might not apply to all targets. Make sure
+                         to check target/linux/<your_target>/image/Makefile to
+                         see if this option will have any effect.
+
+               config TARGET_ROOTFS_INCLUDE_ZIMAGE
+                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
+                       default y
+                       help
+                         This option might not apply to all targets. Make sure
+                         to check target/linux/<your_target>/image/Makefile to
+                         see if this option will have any effect.
+
+               config TARGET_ROOTFS_INCLUDE_FIT
+                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
+                       default y
+                       help
+                         This option might not apply to all targets. Make sure
+                         to check target/linux/<your_target>/image/Makefile to
+                         see if this option will have any effect.
+
        config TARGET_ROOTFS_INCLUDE_DTB
                bool "Include DTB in root filesystem"
                depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS