build: clean menuconfig utility as part of dirclean
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 10 Mar 2020 15:13:40 +0000 (15:13 +0000)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Tue, 10 Mar 2020 20:44:30 +0000 (20:44 +0000)
When sharing a common build directory between different build platforms
eg. macos v docker based linux v virtual machine, a 'make dirclean'
isn't quite enough to clean all the platform related binaries.  The
'conf' and 'mconf' aka 'make menuconfig/defconfig & friends' utilities
remain.

Clean those as part of 'dirclean' so they get rebuilt for the current
platform on the next 'make'

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Makefile

index 181c33b180f2016f6e1ce33c96b53791980ce940..fd705a37ad827cb72ec9a7f85d794a1d4e9f8158 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,7 @@ clean: FORCE
 dirclean: clean
        rm -rf $(STAGING_DIR_HOST) $(STAGING_DIR_HOSTPKG) $(TOOLCHAIN_DIR) $(BUILD_DIR_BASE)/host $(BUILD_DIR_BASE)/hostpkg $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
+       $(MAKE) -C $(TOPDIR)/scripts/config clean
 
 ifndef DUMP_TARGET_DB
 $(BUILD_DIR)/.prepared: Makefile