kernel: bump 5.4 to 5.4.32
authorPetr Štetiar <ynezz@true.cz>
Tue, 14 Apr 2020 15:55:55 +0000 (17:55 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 14 Apr 2020 19:58:16 +0000 (21:58 +0200)
Refreshed patches, removed upstreamed patches:

 generic: 746-stable-net-dsa-mt7530-fix-null-pointer-dereferencing-in-por.patch

Run tested: qemu-x86-64, apalis
Build tested: x86/64, imx6, sunxi/a53

Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/kernel-version.mk
target/linux/ath79/patches-5.4/410-spi-ath79-Implement-the-spi_mem-interface.patch
target/linux/generic/backport-5.4/745-v5.7-net-dsa-mt7530-add-support-for-port-mirroring.patch
target/linux/generic/backport-5.4/746-stable-net-dsa-mt7530-fix-null-pointer-dereferencing-in-por.patch [deleted file]
target/linux/generic/pending-5.4/001-v5.4-pinctrl-qcom-fix-wrong-write-in-update_dual_edge.patch.patch
target/linux/ipq40xx/patches-5.4/304-mtd-spi-nor-Add-support-for-mx25r3235f.patch

index 860a2cd2855f625b67512126ad2afa140e29222a..4a720da24943940f92f632df0b0f12359c7532ad 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.14 = .172
 LINUX_VERSION-4.19 = .108
-LINUX_VERSION-5.4 = .31
+LINUX_VERSION-5.4 = .32
 
 LINUX_KERNEL_HASH-4.14.172 = 2318a1ab937580a079351ed20557c336a3d95b664f667b14e3ba49e3271b217a
 LINUX_KERNEL_HASH-4.19.108 = 09aeeca5b08efea2f54b977b2999afb60d42f93b9f65b2b0111969f183f750a3
-LINUX_KERNEL_HASH-5.4.31 = a11083f8f809887f6a0f8d4467532385b99418f17998fe6e837807491c276eeb
+LINUX_KERNEL_HASH-5.4.32 = 192d99fab7a47a537493b6d7eddb52892b98f8ada655c0bbb419b360a995f2b3
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 81a328f8f6ceb4d1b916a756d90f49dc33e09765..2a6b9857fb5cc2e9327beac4231868f577586609 100644 (file)
@@ -8,10 +8,8 @@ Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
  drivers/spi/spi-ath79.c | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)
 
-Index: linux-5.4.22/drivers/spi/spi-ath79.c
-===================================================================
---- linux-5.4.22.orig/drivers/spi/spi-ath79.c
-+++ linux-5.4.22/drivers/spi/spi-ath79.c
+--- a/drivers/spi/spi-ath79.c
++++ b/drivers/spi/spi-ath79.c
 @@ -15,6 +15,7 @@
  #include <linux/platform_device.h>
  #include <linux/io.h>
index 41855472645ecd5ed86b36e4b084c1a9094b81e4..acd09013afc1c60088a4eb10c17b9262abb5ce48 100644 (file)
@@ -82,7 +82,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static enum dsa_tag_protocol
  mtk_get_tag_protocol(struct dsa_switch *ds, int port)
  {
-@@ -1606,6 +1664,8 @@ static const struct dsa_switch_ops mt753
+@@ -1609,6 +1667,8 @@ static const struct dsa_switch_ops mt753
        .port_vlan_prepare      = mt7530_port_vlan_prepare,
        .port_vlan_add          = mt7530_port_vlan_add,
        .port_vlan_del          = mt7530_port_vlan_del,
diff --git a/target/linux/generic/backport-5.4/746-stable-net-dsa-mt7530-fix-null-pointer-dereferencing-in-por.patch b/target/linux/generic/backport-5.4/746-stable-net-dsa-mt7530-fix-null-pointer-dereferencing-in-por.patch
deleted file mode 100644 (file)
index 1775bfb..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0452800f6db4ed0a42ffb15867c0acfd68829f6a Mon Sep 17 00:00:00 2001
-From: Chuanhong Guo <gch981213@gmail.com>
-Date: Fri, 3 Apr 2020 19:28:24 +0800
-Subject: net: dsa: mt7530: fix null pointer dereferencing in port5 setup
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-The 2nd gmac of mediatek soc ethernet may not be connected to a PHY
-and a phy-handle isn't always available.
-Unfortunately, mt7530 dsa driver assumes that the 2nd gmac is always
-connected to switch port 5 and setup mt7530 according to phy address
-of 2nd gmac node, causing null pointer dereferencing when phy-handle
-isn't defined in dts.
-This commit fix this setup code by checking return value of
-of_parse_phandle before using it.
-
-Fixes: 38f790a80560 ("net: dsa: mt7530: Add support for port 5")
-Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-Reviewed-by: Vivien Didelot <vivien.didelot@gmail.com>
-Reviewed-by: Florian Fainelli <f.fainelli@gmail.com>
-Tested-by: René van Dorst <opensource@vdorst.com>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- drivers/net/dsa/mt7530.c | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/drivers/net/dsa/mt7530.c
-+++ b/drivers/net/dsa/mt7530.c
-@@ -1411,6 +1411,9 @@ mt7530_setup(struct dsa_switch *ds)
-                               continue;
-                       phy_node = of_parse_phandle(mac_np, "phy-handle", 0);
-+                      if (!phy_node)
-+                              continue;
-+
-                       if (phy_node->parent == priv->dev->of_node->parent) {
-                               interface = of_get_phy_mode(mac_np);
-                               id = of_mdio_parse_addr(ds->dev, phy_node);
index e295311116313f5b919ee43c58bb6981a428ec76..b9015236f494423f083fe3c2899dda31c7051158 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  drivers/pinctrl/qcom/pinctrl-msm.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/drivers/pinctrl/qcom/pinctrl-msm.c b/drivers/pinctrl/qcom/pinctrl-msm.c
-index 1a948c3f54b7..9f1c9951949e 100644
 --- a/drivers/pinctrl/qcom/pinctrl-msm.c
 +++ b/drivers/pinctrl/qcom/pinctrl-msm.c
-@@ -692,7 +692,7 @@ static void msm_gpio_update_dual_edge_pos(struct msm_pinctrl *pctrl,
+@@ -688,7 +688,7 @@ static void msm_gpio_update_dual_edge_po
  
                pol = msm_readl_intr_cfg(pctrl, g);
                pol ^= BIT(g->intr_polarity_bit);
@@ -26,6 +24,3 @@ index 1a948c3f54b7..9f1c9951949e 100644
  
                val2 = msm_readl_io(pctrl, g) & BIT(g->in_bit);
                intstat = msm_readl_intr_status(pctrl, g);
--- 
-2.25.1
-
index 476673077d5cf1d6456b35c78634223cda133cb9..ba0447b20e1e5b61295a7d8aef0b838c1d6c1171 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/drivers/mtd/spi-nor/spi-nor.c
 +++ b/drivers/mtd/spi-nor/spi-nor.c
-@@ -2286,6 +2286,8 @@ static const struct flash_info spi_nor_i
+@@ -2313,6 +2313,8 @@ static const struct flash_info spi_nor_i
        { "mx25u6435f",  INFO(0xc22537, 0, 64 * 1024, 128, SECT_4K) },
        { "mx25l12805d", INFO(0xc22018, 0, 64 * 1024, 256, 0) },
        { "mx25l12855e", INFO(0xc22618, 0, 64 * 1024, 256, 0) },