kernel: add gpio-it87
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 29 Apr 2020 13:54:06 +0000 (15:54 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 3 Jun 2020 14:49:28 +0000 (16:49 +0200)
Since commit 910df3f06cc902ca2cb0ca8e963e9354c930df1a we have build in
on all X86/64 platforms the gpio-it87 driver.

Since this change I am getting the following error message on boot.
 > kern.err kernel: [    1.009416] gpio_it87: no device

I do not have this device on my system. To prevent the nonsensical
message and the loading of the module I have added this as a package, so
that it can be installed later or during image building.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Reviewed-by: Philip Prindeville <philipp@redfish-solutions.com>
package/kernel/linux/modules/other.mk
target/linux/x86/64/config-4.19
target/linux/x86/64/config-5.4

index f05c75834016e519330302b95bc44837fa7702cc..2cd4765196888a81e04316c86cbe00af44b6a111 100644 (file)
@@ -295,6 +295,24 @@ endef
 $(eval $(call KernelPackage,gpio-pcf857x))
 
 
+define KernelPackage/gpio-it87
+  SUBMENU:=$(OTHER_MENU)
+  DEPENDS:=@GPIO_SUPPORT @TARGET_x86
+  TITLE:=GPIO support for IT87xx Super I/O chips
+  KCONFIG:=CONFIG_GPIO_IT87
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-it87.ko
+  AUTOLOAD:=$(call AutoLoad,25,gpio-it87,1)
+endef
+
+define KernelPackage/gpio-it87/description
+  This driver is tested with ITE IT8728 and IT8732 Super I/O chips, and
+  supports the IT8761E, IT8613, IT8620E, and IT8628E Super I/O chips as
+  well.
+endef
+
+$(eval $(call KernelPackage,gpio-it87))
+
+
 define KernelPackage/ppdev
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Parallel port support
index 00ed09a4a62f2974f963733678eaf970e87f5d4f..eafae899dde42c99d9a806c086d6877b34bd88d2 100644 (file)
@@ -218,7 +218,7 @@ CONFIG_GPIOLIB=y
 CONFIG_GPIOLIB_IRQCHIP=y
 CONFIG_GPIO_ACPI=y
 CONFIG_GPIO_ICH=y
-CONFIG_GPIO_IT87=y
+# CONFIG_GPIO_IT87 is not set
 CONFIG_GPIO_LYNXPOINT=y
 CONFIG_GPIO_SCH=y
 CONFIG_GPIO_SYSFS=y
index 2c2d06e7504a8179d038c8baa84a6deeacfb2481..1b44103d112b3397bf90f07eba018c85217c15fa 100644 (file)
@@ -192,7 +192,7 @@ CONFIG_GPIOLIB=y
 CONFIG_GPIOLIB_IRQCHIP=y
 CONFIG_GPIO_ACPI=y
 CONFIG_GPIO_ICH=y
-CONFIG_GPIO_IT87=y
+# CONFIG_GPIO_IT87 is not set
 CONFIG_GPIO_LYNXPOINT=y
 CONFIG_GPIO_SCH=y
 CONFIG_GPIO_SYSFS=y