apm821xx: set DEVICE_TYPE to "nas" for sata subtarget
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 30 May 2020 09:21:08 +0000 (11:21 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jun 2020 13:41:09 +0000 (15:41 +0200)
Since DEVICE_TYPE cannot be set per device, just set DEVICE_TYPE
to "nas" for the entire subtarget, which only contains this single
device.

Note that while this looks like a cosmetic change in combination
with the previous patches, this particular patch actually changes
the packages for the device.

Suggested-by: Christian Lamparter <chunkeey@gmail.com>
Cc: Christian Lamparter <chunkeey@gmail.com>
Cc: Sungbo Eo <mans0n@gorani.run>
Cc: Linus Walleij <linus.walleij@linaro.org>
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/apm821xx/sata/target.mk

index d3af6ef82105e6edfb419725c629ce2b8229ddd8..43b1aa03247165a42c37dabb01cf221fe9a05f20 100644 (file)
@@ -1,4 +1,5 @@
 BOARDNAME := Devices which boot from SATA (NAS)
+DEVICE_TYPE := nas
 FEATURES += ext4 usb ramdisk squashfs rootfs-part boot-part
 DEFAULT_PACKAGES += badblocks block-mount e2fsprogs kmod-hwmon-drivetemp \
                    kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck