ath79: do not build TP-Link tiny images by default master
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Jun 2020 11:41:27 +0000 (13:41 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 27 Jun 2020 22:33:44 +0000 (00:33 +0200)
For quite some time, the tiny (4M flash) TP-Link sysupgrade and
factory images cannot be built anymore by the buildbots, just
the initramfs-kernel.bin files are still there.

Disable these images for the buildbots and prevent useless builds.

Note that these devices still build fine with default settings,
even for kernel 5.4.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/common-tp-link.mk
target/linux/ath79/image/tiny-tp-link.mk

index 81a557df4871397c5ac58534c9140d6a853b5f56..3ae377f78f157e89acc62f709958c2f6f4593d8d 100644 (file)
@@ -48,12 +48,14 @@ define Device/tplink-4m
   $(Device/tplink-nolzma)
   TPLINK_FLASHLAYOUT := 4M
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-4mlzma
   $(Device/tplink-v1)
   TPLINK_FLASHLAYOUT := 4Mlzma
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-8m
index 4926084597d4b36c9e23f8b70d843162791392e9..0da712c5d4e9fd72d8989b0f5551bb19b7adef9b 100644 (file)
@@ -157,6 +157,7 @@ define Device/tplink_tl-wa850re-v2
   TPLINK_HWID := 0x08500002
   DEVICE_PACKAGES := rssileds
   SUPPORTED_DEVICES += tl-wa850re-v2
+  DEFAULT := n
 endef
 TARGET_DEVICES += tplink_tl-wa850re-v2