tools: libelf: install pkg-config file
[oweals/openwrt.git] / tools / libelf / Makefile
index 31e2eaf0a8254ff13535f667780a921a3bca2bf2..9fec8308b557c50adee14f263bcc45f3b1f89d7c 100644 (file)
@@ -37,15 +37,17 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib/pkgconfig,include/libelf}
        $(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
                                                $(STAGING_DIR_HOST)/include/libelf/
        $(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
+       $(CP) $(HOST_BUILD_DIR)/libelf.pc $(STAGING_DIR_HOST)/lib/pkgconfig/
 endef
 
 define Host/Clean
        rm -rf $(STAGING_DIR_HOST)/include/libelf
        rm -f $(STAGING_DIR_HOST)/lib/libelf.a
+       rm -f $(STAGING_DIR_HOST)/lib/pkgconfig/libelf.pc
        $(call Host/Clean/Default)
 endef