ipq40xx: add support for EnGenius EMR3500
[oweals/openwrt.git] / tools / flex / Makefile
index ca9aa989893640b8422c555c26eea778ca6fef32..bb5aecbdfeadeef0f3803c6e9678b1de5a31978e 100644 (file)
@@ -7,6 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
+PKG_CPE_ID:=cpe:/a:flex_project:flex
 PKG_VERSION:=2.6.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -15,12 +16,16 @@ PKG_HASH:=e87aae032bf07c26f85ac0ed3250998c37621d95f8bd748b31f15b33c45ee995
 
 HOST_FIXUP:=autoreconf
 HOST_BUILD_PARALLEL:=1
-HOST_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)