toolchain: ARM: Fix option conflict with multiarch
[oweals/openwrt.git] / toolchain / gcc / common.mk
index 6e8767f707b7927b95a01ed66dde4da70ed71fee..6e0edfb36a21061e9d39f90e49bf0b6bfb689085 100644 (file)
@@ -170,6 +170,11 @@ ifeq ($(CONFIG_arm),y)
                --with-fpu=$(word 2, $(subst +, ",$(CONFIG_CPU_TYPE))) \
                --with-float=hard
   endif
+
+  # Do not let TARGET_CFLAGS get poisoned by extra CPU optimization flags
+  # that do not belong here. The cpu,fpu type should be specified via
+  # --with-cpu and --with-fpu for ARM and not CFLAGS.
+  TARGET_CFLAGS:=$(filter-out -m%,$(call qstrip,$(TARGET_CFLAGS)))
 endif
 
 ifeq ($(CONFIG_TARGET_x86)$(CONFIG_USE_GLIBC)$(CONFIG_INSTALL_GCCGO),yyy)