kernel: add pcengines-apu2 module description
[oweals/openwrt.git] / target / linux / x86 / modules.mk
index c8722938d3615e31c0a575e6e6706e5f3bcaa6d5..61ab400dc9d4950cdec9c9dc95a069f59abe6bfb 100644 (file)
@@ -34,3 +34,20 @@ define KernelPackage/sp5100-tco/description
 endef
 
 $(eval $(call KernelPackage,sp5100-tco))
+
+
+define KernelPackage/pcengines-apuv2
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PC Engines APUv2/3 front button and LEDs driver
+  DEPENDS:=@TARGET_x86 +kmod-gpio-amd-fch +kmod-leds-gpio
+  KCONFIG:=CONFIG_PCENGINES_APU2
+  FILES:=$(LINUX_DIR)/drivers/platform/x86/pcengines-apuv2.ko
+  AUTOLOAD:=$(call AutoLoad,60,pcengines-apuv2)
+endef
+
+define KernelPackage/pcengines-apuv2/description
+  This driver provides support for the front button and LEDs on
+  PC Engines APUv2/APUv3 board.
+endef
+
+$(eval $(call KernelPackage,pcengines-apuv2))