kernel: move b43 install function to broadcom.mk
[oweals/openwrt.git] / target / linux / brcm63xx / dts / spw500v.dts
index 9c1feff376a80a2dbae212eed93d1629ed38bf5e..8ca6dddd101d811f143a58f7ab4c9560e4700a05 100644 (file)
@@ -1,48 +1,55 @@
 /dts-v1/;
 
-/include/ "bcm6348.dtsi"
+#include "bcm6348.dtsi"
+
+#include <dt-bindings/input/input.h>
 
 / {
        model = "T-Com Speedport W500 V";
        compatible = "t-com,spw500v", "brcm,bcm6348";
 
-       gpio-keys-polled {
+       chosen {
+               bootargs = "rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       keys {
                compatible = "gpio-keys-polled";
                #address-cells = <1>;
                #size-cells = <0>;
                poll-interval = <20>;
-               debounce-interval = <60>;
 
                reset {
                        label = "reset";
-                       gpios = <&gpio1 1 1>;
-                       linux,code = <0x198>;
+                       gpios = <&pinctrl 33 1>;
+                       linux,code = <KEY_RESTART>;
+                       debounce-interval = <60>;
                };
        };
 
-       gpio-leds {
+       leds {
                compatible = "gpio-leds";
 
                power_green {
                        label = "SPW500V:green:power";
-                       gpios = <&gpio0 0 1>;
+                       gpios = <&pinctrl 0 1>;
                        default-state = "on";
                };
                power_red {
                        label = "SPW500V:red:power";
-                       gpios = <&gpio0 1 1>;
+                       gpios = <&pinctrl 1 1>;
                };
                ppp_green {
                        label = "SPW500V:green:ppp";
-                       gpios = <&gpio0 3 1>;
+                       gpios = <&pinctrl 3 1>;
                };
                pstn_green {
                        label = "SPW500V:green:pstn";
-                       gpios = <&gpio0 28 1>;
+                       gpios = <&pinctrl 28 1>;
                };
                voip_green {
                        label = "SPW500V:green:voip";
-                       gpios = <&gpio1 0 1>;
+                       gpios = <&pinctrl 32 1>;
                };
        };
 };
 &pflash {
        status = "ok";
 
-       linux,part-probe = "bcm63xxpart";
+       partitions {
+               compatible = "fixed-partitions";
+               #address-cells = <1>;
+               #size-cells = <1>;
 
-       cfe@0 {
-               label = "CFE";
-               reg = <0x000000 0x010000>;
-               read-only;
-       };
+               cfe@0 {
+                       label = "CFE";
+                       reg = <0x000000 0x010000>;
+                       read-only;
+               };
 
-       linux@10000 {
-               label = "linux";
-               reg = <0x010000 0x3e0000>;
-       };
+               linux@10000 {
+                       label = "linux";
+                       reg = <0x010000 0x3e0000>;
+                       compatible = "brcm,bcm963xx-imagetag";
+               };
 
-       nvram@3f0000 {
-               label = "nvram";
-               reg = <0x3f0000 0x010000>;
+               nvram@3f0000 {
+                       label = "nvram";
+                       reg = <0x3f0000 0x010000>;
+               };
        };
 };
+
+&pinctrl {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_pci>;
+};
+
+&uart0 {
+       status = "ok";
+};