brcm47xx: rename target to bcm47xx
[oweals/openwrt.git] / target / linux / bcm47xx / generic / profiles / 104-Broadcom-ath5k.mk
diff --git a/target/linux/bcm47xx/generic/profiles/104-Broadcom-ath5k.mk b/target/linux/bcm47xx/generic/profiles/104-Broadcom-ath5k.mk
new file mode 100644 (file)
index 0000000..ca5295f
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-ath5k
+  NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
+  PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
+endef
+
+define Profile/Broadcom-ath5k/Description
+       Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+       SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+       b44, tg3 or bgmac Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-ath5k))
+