ath79: add support for Compex WPJ531 (16M)
[oweals/openwrt.git] / target / linux / ath79 / image / generic.mk
index 9f296adaa754c5bd96944fe6c6f39031b20ad1d9..35def342502e2e7234dff4f7c2b264b68a136c5c 100644 (file)
@@ -418,6 +418,17 @@ define Device/comfast_cf-wr752ac-v1
 endef
 TARGET_DEVICES += comfast_cf-wr752ac-v1
 
+define Device/compex_wpj531-16m
+  SOC := qca9531
+  DEVICE_PACKAGES := kmod-usb2
+  IMAGE_SIZE := 16128k
+  DEVICE_VENDOR := Compex
+  DEVICE_MODEL := WPJ531
+  DEVICE_VARIANT := 16M
+  SUPPORTED_DEVICES += wpj531
+endef
+TARGET_DEVICES += compex_wpj531-16m
+
 define Device/devolo_dvl1200e
   SOC := qca9558
   DEVICE_VENDOR := devolo