bcm47xx: add support for NETGEAR R6200 V1
[oweals/openwrt.git] / target / linux / at91 / Makefile
index 2f86b311d0ceb627163615e11abc4e172c9afef3..4780210f36f87e92a6a82d1eaaf2bfc3cd5e4b6c 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,19 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=NetusG20
-FEATURES:=squashfs jffs2 tgz
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+SUBTARGETS:=sama5 sam9x
 
-LINUX_VERSION:=2.6.34
-DEVICE_TYPE=
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-define Target/Description
-       Build firmware images for Acmesystems NetusG20 board
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))