brcm47xx: rename target to bcm47xx
[oweals/openwrt.git] / package / utils / nvram / Makefile
index c5a4ca480abe3a03d28f488157c4c01ea0280e73..76c254ac77cfe8b32f747815d03e0a241821c6b5 100644 (file)
@@ -21,7 +21,7 @@ define Package/nvram
   CATEGORY:=Base system
   TITLE:=Userspace port of the Broadcom NVRAM manipulation tool
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
-  DEPENDS:=@TARGET_brcm47xx||@TARGET_bcm53xx||@TARGET_ar71xx
+  DEPENDS:=@(TARGET_bcm47xx||TARGET_bcm53xx||TARGET_ar71xx||TARGET_ath79)
 endef
 
 define Package/nvram/description
@@ -29,11 +29,6 @@ define Package/nvram/description
  It works on bcm47xx (Linux 2.6) without using the kernel api.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
 define Build/Configure
 endef
 
@@ -47,7 +42,7 @@ endef
 define Package/nvram/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
-ifneq ($(CONFIG_TARGET_brcm47xx),)
+ifneq ($(CONFIG_TARGET_bcm47xx),)
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
 endif