brcm47xx: rename target to bcm47xx
[oweals/openwrt.git] / package / system / mtd / src / Makefile
index 27ac339005fa7ec3c5bd8127f314d39e489dc804..7299d4d42fdb98cd01bf61f897f1be6a2df3a34f 100644 (file)
@@ -4,12 +4,21 @@ LDFLAGS += -lubox
 
 obj = mtd.o jffs2.o crc32.o md5.o
 obj.seama = seama.o md5.o
-obj.ar71xx = trx.o $(obj.seama)
+obj.wrg = wrg.o md5.o
+obj.wrgg = wrgg.o md5.o
+obj.tpl = tpl_ramips_recoveryflag.o
+obj.ar71xx = trx.o $(obj.seama) $(obj.wrgg)
+obj.ath79 = $(obj.seama)
+obj.gemini = $(obj.wrgg)
 obj.brcm = trx.o
-obj.brcm47xx = $(obj.brcm)
-obj.bcm53xx = $(obj.brcm)
+obj.bcm47xx = $(obj.brcm)
+obj.bcm53xx = $(obj.brcm) $(obj.seama)
 obj.brcm63xx = imagetag.o
-obj.ramips = $(obj.seama)
+obj.ramips = $(obj.seama) $(obj.tpl) $(obj.wrg)
+obj.mvebu = linksys_bootcount.o
+obj.kirkwood = linksys_bootcount.o
+obj.ipq806x = linksys_bootcount.o
+obj.ipq40xx = linksys_bootcount.o
 
 ifdef FIS_SUPPORT
   obj += fis.o