hostapd: bring back mesh patches
[oweals/openwrt.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index bfab382985d042f98f1365f460323c880e87cd84..23bdaa7a1b1a77ca53708d37f433a496ed963bc3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -165,6 +165,11 @@ OBJS += ../src/common/hw_features_common
+@@ -167,6 +167,11 @@ OBJS += ../src/common/hw_features_common
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
  CFLAGS += -O0 -fprofile-arcs -ftest-coverage
 --- a/src/ap/hostapd.h
 +++ b/src/ap/hostapd.h
-@@ -13,6 +13,7 @@
+@@ -17,6 +17,7 @@
  #include "utils/list.h"
  #include "ap_config.h"
  #include "drivers/driver.h"
 +#include "ubus.h"
  
- struct wpa_ctrl_dst;
- struct radius_server_data;
-@@ -119,6 +120,7 @@ struct hostapd_data {
+ #define OCE_STA_CFON_ENABLED(hapd) \
+       ((hapd->conf->oce & OCE_STA_CFON) && \
+@@ -80,7 +81,7 @@ struct hapd_interfaces {
+ #ifdef CONFIG_CTRL_IFACE_UDP
+        unsigned char ctrl_iface_cookie[CTRL_IFACE_COOKIE_LEN];
+ #endif /* CONFIG_CTRL_IFACE_UDP */
+-
++      struct ubus_object ubus;
+ };
+ enum hostapd_chan_status {
+@@ -154,6 +155,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
        unsigned int disabled:1;
-@@ -328,6 +330,8 @@ struct hostapd_iface {
-       struct hostapd_config *conf;
-       char phy[16]; /* Name of the PHY (radio) */
-+      struct hostapd_ubus_iface ubus;
-+
-       enum hostapd_iface_state {
-               HAPD_IFACE_UNINITIALIZED,
-               HAPD_IFACE_DISABLED,
+@@ -603,6 +605,7 @@ hostapd_alloc_bss_data(struct hostapd_if
+                      struct hostapd_bss_config *bss);
+ int hostapd_setup_interface(struct hostapd_iface *iface);
+ int hostapd_setup_interface_complete(struct hostapd_iface *iface, int err);
++void hostapd_set_own_neighbor_report(struct hostapd_data *hapd);
+ void hostapd_interface_deinit(struct hostapd_iface *iface);
+ void hostapd_interface_free(struct hostapd_iface *iface);
+ struct hostapd_iface * hostapd_alloc_iface(void);
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -302,6 +302,7 @@ static void hostapd_free_hapd_data(struc
-       hapd->started = 0;
+@@ -395,6 +395,7 @@ static void hostapd_free_hapd_data(struc
+       hapd->beacon_set_done = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
 +      hostapd_ubus_free_bss(hapd);
-       iapp_deinit(hapd->iapp);
-       hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -1160,6 +1161,8 @@ static int hostapd_setup_bss(struct host
+       hostapd_deinit_wpa(hapd);
+       vlan_deinit(hapd);
+@@ -1413,6 +1414,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1683,6 +1686,7 @@ static int hostapd_setup_interface_compl
+@@ -1988,6 +1991,7 @@ static int hostapd_setup_interface_compl
        if (err)
                goto fail;
  
 +      hostapd_ubus_add_iface(iface);
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
-       if (iface->conf->channel) {
+       if (iface->freq) {
  #ifdef NEED_AP_MLME
-@@ -1862,6 +1866,7 @@ dfs_offload:
+@@ -2185,6 +2189,7 @@ dfs_offload:
  
  fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
@@ -74,7 +82,7 @@
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
        wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
  #ifdef CONFIG_FST
-@@ -2310,6 +2315,7 @@ void hostapd_interface_deinit_free(struc
+@@ -2658,6 +2663,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -1293,7 +1293,8 @@ void ieee802_11_finish_fils_auth(struct
- static void handle_auth(struct hostapd_data *hapd,
--                      const struct ieee80211_mgmt *mgmt, size_t len)
-+                      const struct ieee80211_mgmt *mgmt, size_t len,
-+                      struct hostapd_frame_info *fi)
- {
+@@ -2252,13 +2252,18 @@ static void handle_auth(struct hostapd_d
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
-@@ -1309,6 +1310,11 @@ static void handle_auth(struct hostapd_d
-       char *identity = NULL;
-       char *radius_cui = NULL;
+       struct sta_info *sta = NULL;
+-      int res, reply_res;
++      int res, reply_res, ubus_resp;
+       u16 fc;
+       const u8 *challenge = NULL;
+       u8 resp_ies[2 + WLAN_AUTH_CHALLENGE_LEN];
+       size_t resp_ies_len = 0;
        u16 seq_ctrl;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_AUTH_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
-       os_memset(&vlan_id, 0, sizeof(vlan_id));
-@@ -1466,6 +1472,14 @@ static void handle_auth(struct hostapd_d
+       if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
+               wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
+@@ -2418,6 +2423,13 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
-+
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
++      ubus_resp = hostapd_ubus_handle_event(hapd, &req);
++      if (ubus_resp) {
 +              wpa_printf(MSG_DEBUG, "Station " MACSTR " rejected by ubus handler.\n",
-+                     MAC2STR(mgmt->sa));
-+              resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
++                      MAC2STR(mgmt->sa));
++              resp = ubus_resp > 0 ? (u16) ubus_resp : WLAN_STATUS_UNSPECIFIED_FAILURE;
 +              goto fail;
 +      }
-+
-       if (res == HOSTAPD_ACL_PENDING) {
-               wpa_printf(MSG_DEBUG, "Authentication frame from " MACSTR
-                          " waiting for an external authentication",
-@@ -2391,7 +2405,7 @@ static u16 send_assoc_resp(struct hostap
- static void handle_assoc(struct hostapd_data *hapd,
-                        const struct ieee80211_mgmt *mgmt, size_t len,
--                       int reassoc)
-+                       int reassoc, struct hostapd_frame_info *fi)
- {
-       u16 capab_info, listen_interval, seq_ctrl, fc;
-       u16 resp = WLAN_STATUS_SUCCESS, reply_res;
-@@ -2399,6 +2413,11 @@ static void handle_assoc(struct hostapd_
-       int left, i;
+       if (res == HOSTAPD_ACL_PENDING)
+               return;
+@@ -4087,7 +4099,7 @@ static void handle_assoc(struct hostapd_
+       int resp = WLAN_STATUS_SUCCESS;
+       u16 reply_res;
+       const u8 *pos;
+-      int left, i;
++      int left, i, ubus_resp;
        struct sta_info *sta;
        u8 *tmp = NULL;
+ #ifdef CONFIG_FILS
+@@ -4300,6 +4312,11 @@ static void handle_assoc(struct hostapd_
+               left = res;
+       }
+ #endif /* CONFIG_FILS */
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_ASSOC_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = rssi,
 +      };
  
-       if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
-                                     sizeof(mgmt->u.assoc_req))) {
-@@ -2518,6 +2537,13 @@ static void handle_assoc(struct hostapd_
-       }
- #endif /* CONFIG_MBO */
+       /* followed by SSID and Supported rates; and HT capabilities if 802.11n
+        * is used */
+@@ -4464,6 +4481,14 @@ static void handle_assoc(struct hostapd_
+                                           pos, left, rssi, omit_rsnxe);
+       os_free(tmp);
  
-+      if (hostapd_ubus_handle_event(hapd, &req)) {
++      ubus_resp = hostapd_ubus_handle_event(hapd, &req);
++      if (ubus_resp) {
 +              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
 +                     MAC2STR(mgmt->sa));
-+              resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
++              resp = ubus_resp > 0 ? (u16) ubus_resp : WLAN_STATUS_UNSPECIFIED_FAILURE;
 +              goto fail;
 +      }
 +
        /*
-        * sta->capability is used in check_assoc_ies() for RRM enabled
-        * capability element.
-@@ -3025,7 +3051,7 @@ int ieee802_11_mgmt(struct hostapd_data
+        * Remove the station in case tranmission of a success response fails
+        * (the STA was added associated to the driver) or if the station was
+@@ -4491,6 +4516,7 @@ static void handle_disassoc(struct hosta
+       wpa_printf(MSG_DEBUG, "disassocation: STA=" MACSTR " reason_code=%d",
+                  MAC2STR(mgmt->sa),
+                  le_to_host16(mgmt->u.disassoc.reason_code));
++      hostapd_ubus_notify(hapd, "disassoc", mgmt->sa);
  
-       if (stype == WLAN_FC_STYPE_PROBE_REQ) {
--              handle_probe_req(hapd, mgmt, len, fi->ssi_signal);
-+              handle_probe_req(hapd, mgmt, len, fi);
-               return 1;
-       }
+       sta = ap_get_sta(hapd, mgmt->sa);
+       if (sta == NULL) {
+@@ -4557,6 +4583,8 @@ static void handle_deauth(struct hostapd
+               " reason_code=%d",
+               MAC2STR(mgmt->sa), le_to_host16(mgmt->u.deauth.reason_code));
  
-@@ -3043,17 +3069,17 @@ int ieee802_11_mgmt(struct hostapd_data
-       switch (stype) {
-       case WLAN_FC_STYPE_AUTH:
-               wpa_printf(MSG_DEBUG, "mgmt::auth");
--              handle_auth(hapd, mgmt, len);
-+              handle_auth(hapd, mgmt, len, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_ASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::assoc_req");
--              handle_assoc(hapd, mgmt, len, 0);
-+              handle_assoc(hapd, mgmt, len, 0, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_REASSOC_REQ:
-               wpa_printf(MSG_DEBUG, "mgmt::reassoc_req");
--              handle_assoc(hapd, mgmt, len, 1);
-+              handle_assoc(hapd, mgmt, len, 1, fi);
-               ret = 1;
-               break;
-       case WLAN_FC_STYPE_DISASSOC:
++      hostapd_ubus_notify(hapd, "deauth", mgmt->sa);
++
+       sta = ap_get_sta(hapd, mgmt->sa);
+       if (sta == NULL) {
+               wpa_msg(hapd->msg_ctx, MSG_DEBUG, "Station " MACSTR " trying "
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -702,7 +702,7 @@ void sta_track_claim_taxonomy_info(struc
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal)
-+                    struct hostapd_frame_info *fi)
- {
-       u8 *resp;
-       struct ieee802_11_elems elems;
-@@ -711,9 +711,15 @@ void handle_probe_req(struct hostapd_dat
-       size_t i, resp_len;
-       int noack;
-       enum ssid_match_result res;
-+      int ssi_signal = fi->ssi_signal;
-       int ret;
+@@ -814,6 +814,12 @@ void handle_probe_req(struct hostapd_dat
        u16 csa_offs[2];
        size_t csa_offs_len;
+       struct radius_sta rad_info;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_PROBE_REQ,
 +              .mgmt_frame = mgmt,
-+              .frame_info = fi,
++              .ssi_signal = ssi_signal,
++              .elems = &elems,
 +      };
  
        if (len < IEEE80211_HDRLEN)
                return;
-@@ -880,6 +886,12 @@ void handle_probe_req(struct hostapd_dat
+@@ -996,6 +1002,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */
  
        /* TODO: verify that supp_rates contains at least one matching rate
         * with AP configuration */
  
---- a/src/ap/beacon.h
-+++ b/src/ap/beacon.h
-@@ -14,7 +14,7 @@ struct ieee80211_mgmt;
- void handle_probe_req(struct hostapd_data *hapd,
-                     const struct ieee80211_mgmt *mgmt, size_t len,
--                    int ssi_signal);
-+                    struct hostapd_frame_info *fi);
- int ieee802_11_set_beacon(struct hostapd_data *hapd);
- int ieee802_11_set_beacons(struct hostapd_iface *iface);
- int ieee802_11_update_beacons(struct hostapd_iface *iface);
 --- a/src/ap/drv_callbacks.c
 +++ b/src/ap/drv_callbacks.c
-@@ -52,6 +52,10 @@ int hostapd_notif_assoc(struct hostapd_d
+@@ -119,6 +119,10 @@ int hostapd_notif_assoc(struct hostapd_d
        u16 reason = WLAN_REASON_UNSPECIFIED;
-       u16 status = WLAN_STATUS_SUCCESS;
+       int status = WLAN_STATUS_SUCCESS;
        const u8 *p2p_dev_addr = NULL;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_ASSOC_REQ,
  
        if (addr == NULL) {
                /*
-@@ -131,6 +135,12 @@ int hostapd_notif_assoc(struct hostapd_d
+@@ -211,6 +215,12 @@ int hostapd_notif_assoc(struct hostapd_d
                goto fail;
        }
  
  #ifdef CONFIG_P2P
        if (elems.p2p) {
                wpabuf_free(sta->p2p_ie);
+--- a/src/ap/sta_info.c
++++ b/src/ap/sta_info.c
+@@ -424,6 +424,7 @@ void ap_handle_timer(void *eloop_ctx, vo
+                              HOSTAPD_LEVEL_INFO, "deauthenticated due to "
+                              "local deauth request");
+               ap_free_sta(hapd, sta);
++              hostapd_ubus_notify(hapd, "local-deauth", sta->addr);
+               return;
+       }
+@@ -579,6 +580,7 @@ skip_poll:
+                       hapd, sta,
+                       WLAN_REASON_PREV_AUTH_NOT_VALID);
+               ap_free_sta(hapd, sta);
++              hostapd_ubus_notify(hapd, "inactive-deauth", sta->addr);
+               break;
+       }
+ }
+@@ -1294,6 +1296,7 @@ void ap_sta_set_authorized(struct hostap
+                                         buf, ip_addr, keyid_buf);
+       } else {
+               wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_DISCONNECTED "%s", buf);
++              hostapd_ubus_notify(hapd, "disassoc", sta->addr);
+               if (hapd->msg_ctx_parent &&
+                   hapd->msg_ctx_parent != hapd->msg_ctx)
+--- a/src/ap/wpa_auth_glue.c
++++ b/src/ap/wpa_auth_glue.c
+@@ -251,6 +251,7 @@ static void hostapd_wpa_auth_psk_failure
+       struct hostapd_data *hapd = ctx;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_STA_POSSIBLE_PSK_MISMATCH MACSTR,
+               MAC2STR(addr));
++      hostapd_ubus_notify(hapd, "key-mismatch", addr);
+ }
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -190,6 +190,12 @@ ifdef CONFIG_EAPOL_TEST
+ CFLAGS += -Werror -DEAPOL_TEST
+ endif
++ifdef CONFIG_UBUS
++CFLAGS += -DUBUS_SUPPORT
++OBJS += ubus.o
++LIBS += -lubox -lubus
++endif
++
+ ifdef CONFIG_CODE_COVERAGE
+ CFLAGS += -O0 -fprofile-arcs -ftest-coverage
+ LIBS += -lgcov
+@@ -883,6 +889,9 @@ OBJS += ../src/pae/ieee802_1x_secy_ops.o
+ ifdef CONFIG_AP
+ OBJS += ../src/ap/wpa_auth_kay.o
+ endif
++ifdef CONFIG_UBUS
++OBJS += ../src/ap/ubus.o
++endif
+ endif
+ ifdef CONFIG_IEEE8021X_EAPOL
+--- a/wpa_supplicant/wpa_supplicant.c
++++ b/wpa_supplicant/wpa_supplicant.c
+@@ -6793,6 +6793,8 @@ struct wpa_supplicant * wpa_supplicant_a
+       }
+ #endif /* CONFIG_P2P */
++      wpas_ubus_add_bss(wpa_s);
++
+       return wpa_s;
+ }
+@@ -6819,6 +6821,8 @@ int wpa_supplicant_remove_iface(struct w
+       struct wpa_supplicant *parent = wpa_s->parent;
+ #endif /* CONFIG_MESH */
++      wpas_ubus_free_bss(wpa_s);
++
+       /* Remove interface from the global list of interfaces */
+       prev = global->ifaces;
+       if (prev == wpa_s) {
+@@ -7122,8 +7126,12 @@ int wpa_supplicant_run(struct wpa_global
+       eloop_register_signal_terminate(wpa_supplicant_terminate, global);
+       eloop_register_signal_reconfig(wpa_supplicant_reconfig, global);
++      wpas_ubus_add(global);
++
+       eloop_run();
++      wpas_ubus_free(global);
++
+       return 0;
+ }
+--- a/wpa_supplicant/wpa_supplicant_i.h
++++ b/wpa_supplicant/wpa_supplicant_i.h
+@@ -17,6 +17,7 @@
+ #include "wps/wps_defs.h"
+ #include "config_ssid.h"
+ #include "wmm_ac.h"
++#include "ubus.h"
+ extern const char *const wpa_supplicant_version;
+ extern const char *const wpa_supplicant_license;
+@@ -310,6 +311,8 @@ struct wpa_global {
+ #endif /* CONFIG_WIFI_DISPLAY */
+       struct psk_list_entry *add_psk; /* From group formation */
++
++      struct ubus_object ubus_global;
+ };
+@@ -520,6 +523,7 @@ struct wpa_supplicant {
+       unsigned char own_addr[ETH_ALEN];
+       unsigned char perm_addr[ETH_ALEN];
+       char ifname[100];
++      struct wpas_ubus_bss ubus;
+ #ifdef CONFIG_MATCH_IFACE
+       int matched;
+ #endif /* CONFIG_MATCH_IFACE */
+--- a/wpa_supplicant/wps_supplicant.c
++++ b/wpa_supplicant/wps_supplicant.c
+@@ -33,6 +33,7 @@
+ #include "p2p/p2p.h"
+ #include "p2p_supplicant.h"
+ #include "wps_supplicant.h"
++#include "ubus.h"
+ #ifndef WPS_PIN_SCAN_IGNORE_SEL_REG
+@@ -392,6 +393,8 @@ static int wpa_supplicant_wps_cred(void
+       wpa_hexdump_key(MSG_DEBUG, "WPS: Received Credential attribute",
+                       cred->cred_attr, cred->cred_attr_len);
++      wpas_ubus_notify(wpa_s, cred);
++
+       if (wpa_s->conf->wps_cred_processing == 1)
+               return 0;
+--- a/hostapd/main.c
++++ b/hostapd/main.c
+@@ -896,6 +896,7 @@ int main(int argc, char *argv[])
+       }
+       hostapd_global_ctrl_iface_init(&interfaces);
++      hostapd_ubus_add(&interfaces);
+       if (hostapd_global_run(&interfaces, daemonize, pid_file)) {
+               wpa_printf(MSG_ERROR, "Failed to start eloop");
+@@ -905,6 +906,7 @@ int main(int argc, char *argv[])
+       ret = 0;
+  out:
++      hostapd_ubus_free(&interfaces);
+       hostapd_global_ctrl_iface_deinit(&interfaces);
+       /* Deinitialize all interfaces */
+       for (i = 0; i < interfaces.count; i++) {
+--- a/wpa_supplicant/main.c
++++ b/wpa_supplicant/main.c
+@@ -203,7 +203,7 @@ int main(int argc, char *argv[])
+       for (;;) {
+               c = getopt(argc, argv,
+-                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:No:O:p:P:qsTtuv::W");
++                         "b:Bc:C:D:de:f:g:G:hH:i:I:KLMm:nNo:O:p:P:qsTtuv::W");
+               if (c < 0)
+                       break;
+               switch (c) {
+@@ -271,6 +271,9 @@ int main(int argc, char *argv[])
+                       params.conf_p2p_dev = optarg;
+                       break;
+ #endif /* CONFIG_P2P */
++              case 'n':
++                      iface_count = 0;
++                      break;
+               case 'o':
+                       params.override_driver = optarg;
+                       break;
+--- a/src/ap/rrm.c
++++ b/src/ap/rrm.c
+@@ -89,6 +89,9 @@ static void hostapd_handle_beacon_report
+               return;
+       wpa_msg(hapd->msg_ctx, MSG_INFO, BEACON_RESP_RX MACSTR " %u %02x %s",
+               MAC2STR(addr), token, rep_mode, report);
++      if (len < sizeof(struct rrm_measurement_beacon_report))
++              return;
++      hostapd_ubus_notify_beacon_report(hapd, addr, token, rep_mode, (struct rrm_measurement_beacon_report*) pos, len);
+ }