build: show make output in scripts/config when V=s
[oweals/openwrt.git] / include / toplevel.mk
index 2965f75c7cd7e66fef5b7562a77f134ff6ddb18f..ad8e5b8f20428e7b81054e367dbc782258f0d43a 100644 (file)
@@ -104,7 +104,8 @@ scripts/config/%onf: export PATH:=$(dir $(DISTRO_PKG_CONFIG)):$(PATH)
 endif
 scripts/config/%onf: CFLAGS+= -O2
 scripts/config/%onf:
-       @$(_SINGLE)$(SUBMAKE) -s -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
+       @$(_SINGLE)$(SUBMAKE) $(if $(findstring s,$(OPENWRT_VERBOSE)),,-s) \
+               -C scripts/config $(notdir $@) CC="$(HOSTCC_WRAPPER)"
 
 $(eval $(call rdep,scripts/config,scripts/config/mconf))