speed up the build system by including include/shell.sh on shell commands only where...
[oweals/openwrt.git] / include / package-ipkg.mk
index 87b142aa594490661ee093cd4a83b07e3e7d3030..82fc209c5bfd10f90a71b412ef4ca6d47c9cca58 100644 (file)
@@ -21,7 +21,7 @@ IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/opkg
 
 define BuildIPKGVariable
   $(call shexport,Package/$(1)/$(2))
-  $(1)_COMMANDS += var2file "$(call shvar,Package/$(1)/$(2))" $(2);
+  $(1)_COMMANDS += $(SH_FUNC) var2file "$(call shvar,Package/$(1)/$(2))" $(2);
 endef
 
 PARENL :=(
@@ -95,7 +95,7 @@ ifeq ($(DUMP),)
                echo "Maintainer: $(MAINTAINER)"; \
                echo "Architecture: $(PKGARCH)"; \
                echo "Installed-Size: 1"; \
-               echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
+               echo -n "Description: "; $(SH_FUNC) getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
        ) >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        (cd $$(IDIR_$(1))/CONTROL; \