From: Jo-Philipp Wich <jo@mein.io>
Date: Tue, 24 Jul 2018 11:36:28 +0000 (+0200)
Subject: build: prereq-build.mk: fix gcc/g++ SetupHostCommand invocation
X-Git-Tag: v18.06.2~204
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=f8750b1a433fc6f590dc5214a90b6b370f8833da;p=oweals%2Fopenwrt.git

build: prereq-build.mk: fix gcc/g++ SetupHostCommand invocation

A missing comma caused the first command option to be considered part of
the error message.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(backported from a6f4c7bce8c62d2dded5c8c12f7f118e2a6c9ee5)
---

diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index edd63e9ee6..029249f69c 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -27,7 +27,7 @@ $(eval $(call TestHostCommand,proper-umask, \
 	umask | grep -xE 00[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
-	Please install the GNU C Compiler (gcc) 4.8 or later \
+	Please install the GNU C Compiler (gcc) 4.8 or later, \
 	$(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
 	gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
 	gcc48 --version | grep gcc, \
@@ -46,7 +46,7 @@ $(eval $(call TestHostCommand,working-gcc, \
 		gcc -x c -o $(TMP_DIR)/a.out -))
 
 $(eval $(call SetupHostCommand,g++, \
-	Please install the GNU C++ Compiler (g++) 4.8 or later \
+	Please install the GNU C++ Compiler (g++) 4.8 or later, \
 	$(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
 	g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
 	g++48 --version | grep g++, \