From: Daniel Engberg <daniel.engberg.lists@pyret.net>
Date: Tue, 24 Jul 2018 11:59:30 +0000 (+0200)
Subject: utils/curl: Disable libpsl
X-Git-Tag: v19.07.0-rc1~3106
X-Git-Url: https://git.librecmc.org/?a=commitdiff_plain;h=f486f81c649fe897f7070cbf14df504aea104029;p=oweals%2Fopenwrt.git

utils/curl: Disable libpsl

Disabled libpsl to fix build issue reported by buildbots

Package libcurl is missing dependencies for the following libraries:
libpsl.so.5


Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
---

diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 157ec3462d..7b93b7f9c1 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 PKG_VERSION:=7.61.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
@@ -113,6 +113,7 @@ CONFIGURE_ARGS += \
 	--without-librtmp \
 	--without-libidn \
 	--without-ca-path \
+	--without-libpsl \
 	--with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
 	\
 	$(call autoconf_bool,CONFIG_IPV6,ipv6) \